Bug in new update .59

Installed this yesterday. 2 problems: every time I start Comodo, I get a popup from Comodo security saying dragon.exe is trying to change my browser settings. I have said no, don’t AND OK, but it still comes up every time. Also when I restarted, my screen resolution was reset to max (tiny print for an old guy) and the resolution setting in Windows (10 32 bit) is grayed out. que pasa?

Sure, it WORKS, it’s just irritating

i will only confirm this - using win7 64 bit - updated yesterday and
dragon keeps trying to make itself default - comodo antivirus warns me.

this takes maybe 1-2 minute after the start - within this time dragon is not responding
this does also affect other browser and the win system itself.
my second browser reports “not responding”

browser and windows taskbar are stalled

trying to close dragon does not work - until the request from comodo av comes up.
cannot open any chrome: adress or any external - nothing.

do you want us to choose another browser?

how can this happen?

Yarp. Exact same problem here. “Dragon.exe is trying to…” blah blah blah, every single time I launch Comodo Dragon after the most recent update. And just like you, I choose to keep my current settings and it ignores me entirely. Quite annoying. But is it the browser update, or was it the Security Essentials Suite update that happened around the same time? Either way, I would like a fix, please. Please?

Additionally - it starts >much< slower and will not connect for updates from Adobe, although other updates are OK ???


So I did all the regular troubleshooting - reinstall Dragon; uninstall/reinstall Dragon; reset browser settings to default; scanned for viruses; checked for errant registry entries; ran CCleaner and cleaned up everything; installed the Portable version of Dragon and had the exact same problem.

I finally decided to start uninstalling Comodo products, starting with Internet Security (CIS). Uninstalled, rebooted, downloaded CIS again, reinstalled, scanned when done, rebooted, and it launched Dragon after login as it does when the CIS install is complete. No error. I closed Dragon, waited a minute, opened it again - no error. A few seconds later CIS gave me a popup asking if I wanted to change the browser settings to Yahoo et al (I know it was CIS because the new version has a very identifiable GUI theme). I unchecked the features check-box and chose the SKIP button.

This is where I think I remember seeing something similar after Dragon did its last update and then the problem started. On this screen the Update features have a check box to the left of them, and a SKIP and PROCEED button at the bottom of the popup. I think what broke it is when Dragon updated recently I originally unchecked the check-box for the features and then I chose the PROCEED button. Selecting PROCEED is what I believe broke something. This time I unchecked the check-box then chose SKIP, and the problem is gone. I may be wrong, but I believe that when you uncheck the check-box for the feature changes, the PROCEED button should grey out so you can ONLY choose SKIP. But when it doesn’t grey out and you choose PROCEED I think the coding may be bad, so it knows you chose PROCEED when you shouldn’t have been able to, so it thinks the settings were changed, but after it was supposedly changed those settings seemingly got reset, and there is likely a registry setting saying it’s supposed to be changed one way but an integrity check shows it’s not, so it keeps asking. Bad cyclical coding. I hope that made some semblance of sense.

Again, I could be wrong, but having worked in I.T. for 20 years and having to track down similar problems with company programmers apps, I’d bet I’m close.

Anyway, uninstall CIS, reboot, reinstall CIS, reboot, and when it eventually asks if you want to change the browser settings, uncheck the features box and choose SKIP. That’s what fixed it for me.

I hope that helps!

OH… One more note.

When I reinstalled Comodo Internet Security I chose not to install Geekbuddy and Dragon as part of the installation so it kept my Dragon install exactly as it was. So I did not reinstall Dragon as part of CIS, so that wasn’t what fixed it (in case any Comodo programmers were going to ask). :wink: