Bug: Defence+ shows 2 but there are none!? [Issue Report]

My Defence+ shows for weeks the number 2 in files that are not recognized. When i click on the number the window opens but nothing is there, totally empty?

att. screendump

The bug/issue

  1. What you did: Nothing
  2. What actually happened or you actually saw: a 2 and nothing in the list
  3. What you expected to happen or see: two lines according to the number 2
  4. How you tried to fix it & what happened: Not
  5. If its an application compatibility problem have you tried the application fixes here?: Not
  6. Details & exact version of any application (execpt CIS) involved with download link: Not
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: It’s there and not gone
  8. Any other information (eg your guess regarding the cause, with reasons): None

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: ?
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List: ?
  3. A CIS config report or file. ?
  4. Crash or freeze dump file: ?

Your set-up

  1. CIS version, AV database version & configuration used: 5.4.xxxx.1355 \ 8961
  2. a) Have you updated (without uninstall) from CIS 3 or 4: Clean
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: Clean
  3. a) Have you imported a config from a previous version of CIS: Clean
    b) if so, have U tried a standard config (without losing settings - if not please do)?: Clean
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): Clean\standard
  5. Defense+, Sandbox, Firewall & AV security levels: D+=Cleanpc , Sandbox=on , Firewall =save , AV =full
  6. OS version, service pack, number of bits, UAC setting, & account type: Win7 sp1 64bit UAC active admin
  7. Other security and utility software installed: none
  8. Virtual machine used (Please do NOT use Virtual box): none

[attachment deleted by admin]

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

WHY WE ASK YOU TO FOLLOW THESE GUIDELINES
Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation

HeffeD

Sorry to inform you bu I got another laptop with the same problem. 53 files reported but none visible!? ???

New Laptop
Windows 7 64bit
Latest Comodo from yesterday.

So after reporting multiple incidents, what can I expect?

bump :-\

Hoi Eljo,

If all is well and dev’s are able to reproduce the issue, it should become fixed in next version.
Can you please save a set of copies of the files in \Program files\Comodo\Comodo Internet Security\Database
Can you also post which files are in there by name, one or two are related to this list and removing them will at least ‘reset’ the counter(s) after reboot.

If you then place the files back and the counter increases and the display stays blank please attach the files here so dev’s can have a look at them why CIS won’t display it’s contents.

Groet,
Ronny

[attachment deleted by admin]

Try moving pending.h to a temp location and reboot see if that takes care of the issue. If so please verify by placing the file back and reboot to see if the issue re-appears.

Can’t remove, locked by Internet Security helper service

Can you try booting safe-mode?

I think the cause is day changing date. I mean the passing from 23:59 to 00:00(11:59 PM to 00:00). In the main windows, Comodo Defence + shows how many incidents occured, no matter what day it is, counting from the starting of OS, in the same session. But in logs, when day changes and you didn’t restart the OS, every incident is erased. They don’t appear even in if you choose “More” and “Current week”.

OK because my laptop totally runs under “TrueCrypt” I had to figure out how to get into safe-mode. Well you have to be quick pushing the F8 ;D

I first copied the two files to a safe location and then deleted the pending files.

  • pending.h
  • pending.n

I rebooted in normal mode and started Comodo IS. The number is now “0”. :-TU

I copied the 2 files back in normal mode and I did a “Diagnostics” of Comodo under the tab “More”. It found some problems but could also fix all.

Then I had to Scan my system because that had never been done according to Comodo IS. It updated the AV db because it was a day behind, that took for ever (10min.) but now I think all is well and working again. 88)

some concerns:

I have clients that have the same problem. I help them with LogMeIn because they live to far away. I can’t restart in safe-mode with LogMeIn. Is there another way to remove these files because they are locked in normal mode. Delete of copy can’t be done past can be done.

Yes you have to kill cmdagent.exe for it, but I’m not sure if LogMeIn is able to survive that or that CIS will start blocking stuff.
To kill cmdagent.exe you have to allow the tool you use to kill (taskmgr or process explorer eg.) it on the Defense+ Computer Security Policy, Comodo Group, Protections tab, process termination. Add it there, after you killed cmdagent.exe you should be able to remove the files, next you can start cmdagent again with the services mmc or use a cmd-box ‘net start cmdagent’.

Sadly to say but today the two files are back :o

Seems like a bug, I’ll notify dev’s.

Thank you for your Issue report.

Moved to verified.

Thank you

Dennis

And after deleting all former Comodo IS 4.x and installing the latest 4.8 I have the same issue :cry:

att. jpeg

[attachment deleted by admin]

This can be worked around by deleting ‘pending.n’ in C:\Program Files\COMODO\COMODO Internet Security\database
After removal pls reboot and see if that helps.

Pending.N deleted and rebooted, 20pcs still there. no effect

Please move all pending.* and submit.* files to a temporary location and reboot on of these files is causing this issue.