Bug COMODO Internet Security 5.8.211697.2124

  1. The full product and its version:COMODO Internet Security 5.8.211697.2124
  2. Your Operating System (32 or 64 bit) and Service Pack revision:windows 7 Professional sp1 32
  3. Other Security and Utility Software Installed:N/A
  4. Step by step description to reproduce the issue:Open the mozilla firefox 7.0.1 and navigate
  5. How you tried to resolve the problem:N/A
  6. Upload Memory Dumps on crash if you encounter any:N/A
  7. Attach screenshots to your posts to clarify the issue further:Attachment.
  8. Any other information you think that might be useful:N/A
  9. The CIS Security profile your using, and if you imported a previous version of the config:default

Ok not really understand the problem with Windows when trying to install a new hardware driver has not been solved, cmdagent.exe cpu is at 40% wear, from version 5.5 to 5.8 same problem was not solved, we must give disable the antivirus to go completely normal. And the same problem is and if ETDctrl.exe, only here the process itself constantly stays at 50% ETDctrl.exe approximate 5-10 minutes, and everything is alternative when and when it happens again that ETDctrl.exe to climb to 50 %. I tried running version 5.5, and 5.8 beta - 5.8 Final, but nothing, I hoped that it will solve the problem, I hope someone to look over my bug report. Please help me. Thanks

[attachment deleted by admin]

From your logs:

  1. You need to allow the files that are hammering CIS in memory access to the CS group. Look here for help. Only if you know you trust them though.

  2. You need to unsandbox the Yahoo file (transfer it from unrecognised to trusted files)

Moving to help for the moment while we work out if this is a bug. Hope that’s OK

Best wishes


Thank you so much I appreciate your interest. Seems good idea, but unfortunately I tried that and still did not work, I tried to disable all shields to give, firewall, defense + … etc, it is surprising that the sudden drop ETDctrl.exe from 50% to 0% with the opening of the main window of CIS 5.8 (when everything is disable firewall, defense +, sandbox, antivirus). I think the problem is more complex, is due to cis 5.5. As additional information avast 6 and Windows 7 firewall, they do not make me any problems, the ETDctrl.exe, behave normally 0-1% cpu usage, behave ‘normally’ for a process belonging to the touch pad. A and another thing why cis 5.8 set as default receives a score below the Comodo leak test, only 150, so little, windows 7 firewall does the same score without too much trouble. Excuse me my opinion a bit too critical, but is very disappointed, I tried everything possible, should be reviewed directly by the guys at Comodo. Thank you.

If you are running Avast 6 as well, even if you have disabled it, unless you have totally uninstalled it, that could be creating your problems.

Avast and cis may be trying to analyse both files at once.

CLT is not designed to test CIS with the sandbox enabled. It has to be used very carefully to give an accurate score. See the D+ FAQ for details.

Best wishes


XP SP 3 32 Bits here.

I get 340/340 for both, test with sandbox & test with D+ only too.


I have now find out that Comodo FW almost still use 50% of CPU.
I have similar problem before and solved it with that that I have added antivirus (NOD32) and Opera to trusted applications.
But now from update (to 5.8.213334.2131) the CPU runs on 50% too and the both apps are still in trusted. So I have now find out that is do not made firewall himself, but the Defense+.

So I have now turned off Defense+ and the CPU use is now normal (0-1%)

i have the same problem with etdctrl(((

I am convinced that you are disappointed, like me, I tried lots of solutions, but in vain. Meanwhile I uninstalled CIS 5.8, however, thanks to the interest of “Valentin N” emailed me some steps how to add the exception ETDctrl.exe process. I would be very curious that you try those steps and you tell me if they are useful and solved incompatibility Comodo - Elantech. You please give me your email address to send you video file. Keep in touch.

i have found the temporal solution: when comodo interface opened there is no problem, so just minimize the comodo interface window.

Hmm you can call a solution, but over time will become stressful, believe me I tried. I hope that the problem users using Elantech’s tochpad be solved by Comodo team. Comodo Internet Security remains one of perfect products. It’s a shame for a small incompatibility to give it to Comodo Internet Security, it is true that only affects some users, we hope that the problem be solved. All the best

I have also noticed high CPU usage by ETDCtrl.exe as indicated by Windows Taskmanager. Since this seems to continue without cease I usually suspend the program with Sysinternals ProcessExplorer. ETDCtrl.exe can probably be uninstalled, at the expense of touchpad usability. I wonder the reason. I have Comodo 5.10 and Acer Aspire 5750G laptop.

You should make a bug report, hoping that version 6 will solve this little inconvenience.