Buffer overflow while generating user's profiled safe list database

Hi everyone,

Every time I run the tool to create the user’s profiled safe list database, the application has to be shut down because of a buffer overflow.

Why is this? What can I do to avoid it?

Should I submit a bug-report (and where)?



How do you get the information of a buffer overflow? Do you use Comodo Memory Guardian?

If you think this is a bug, you can look here how to submit a ticket (bug-report).


A C++ message box pops up and imforms me, that due to a buffer overflow the application has to be halted

Such buffer overflows are usually a programming issue. I have not come across anyone else reporting this.

ulriks, what operating system do you use, how much RAM have you got and what speed is your processor?


Hi Ulrik,

Do you got this problem always while profiling on same file? If it is, can you please provide us the file information?


Sorry for the lag time.

I am running
Windows 2000 SP4
384 Mb RAM
Intel, 850 mHz

It appeared to run in to the buffer owerflow at ‘desktop.ini’ in Local Settings/Temp/Temporary Internet Files. I emptied the Temporary Internet Files but to no awail.

Also a system search for desktop.ini only finds three and none in Local Settings/Temp/Temporary Internet Files


When you start the profiler, if you look at advanced settings you could try marking the Temp folder as Safe and see if it solves your problem.


Good idea! Unfortunately, the ‘safe’ paths are still being searched.

I found that in Local Settings/Temp/Temporary Internet Files I had a file with a very, very long file name (path "name was more than 255 chars). I removed it using a tool called PurgeIE, from DelinvFile - Utility for Deleting Invalid Files and Folders

Once removed, I could perfom a full scann without any issues.

The offencing wile was not the desktop.ini, but the file after that in the directory.

Should I submit a bugreport?



Please see umesh’s post on page 2 of this thread; he’s attached a zip archive with some files to replace…