BT Speedtester site - access problem

Wonder if anyone could help with this please?
Whenever I try and access this site:
NM logs this:

Date/Time :2007-03-13 18:09:55
Severity :Medium
Reporter :Network Monitor
Description:Inbound Policy Violation (Access Denied, ICMP = UNREACHABLE)
Protocol:ICMP IncomingSource: Destination:
Reason: Network Control Rule ID = 7

I’ve tried turning off the NM, but same thing. Is it something to do with my router’s firewall maybe?
Any suggestions gratefully received!

I don’t know but if you want to test your connection speed try this site .

Thanks for the link, but I really need the BT one, since they log the speeds to my ISP (BT Broadband)

I’m sorry, I know it’s free and all, but CFP is really beginning to annoy me now I understand the need for online security, but this feels like I’m bricking up all the windows and doors in my house, just in case a burglar wanders by, and every time friends or family come around, they’re only allowed to get in by squeezing through a hole made by removing one brick - and I don’t know which brick of the thousands I need to remove!

Pursuing this issue (BT Speedtester), I discovered that since installation, Comodo had been silently blocking windows time update (ok, not crucial, but I like my clock to be right!). There was nothing in the CFP log for this, but the Windows log showes an ICMP related error.
So, I tried the BT speedtester site, and noted the IP address. I then created a NM rule at the top of the list allowing ICMP in from that IP address. I tried the site again - “unable to connect” (I know the site’s ok, I can get to it from behind my corporate proxy firewall at work).
So, I add ICMP In/Out to the rule - CFP logs nothing, but I can’t get the site. Next, I switch off NM - nothing. Next, I exit CFP - the warning assures me that I will no longer be protected - still nothing.
So, having read a few posts on here, I up the frequency of alerts, and untick the "do not show alerts…Comodo certified etc…). I try again - still nothing.

To be honest, I’m now spending an inordinate amount of time trying to troubleshoot connection problems instead of getting on with what I need to do, and it’s becoming really, really tiresome. Sure, CFP has a small footprint and low resource uses and I’m sure it really is the strongest available leak-proof hacker-proof firewall the world has ever known - but I have a better method - unplug the network cable. For me it’s much the same result!- I can’t do what I want with my own computer. Ironically, I feel like it’s been taken over and controlled…
Sorry for the rant, but I’ve had enough!