BSODs on Win7 x64 with "Enhanced Protection Mode"

TOPIC TITLE
Blue Screen of Death on startup when enabling “Enhanced Protection Mode” in Defense+
(The error is repeatable with a freshly installed Windows 7 + Comodo with nothing else installed, except drivers.)


A. THE BUG/ISSUE:

  1. What you did:
    I started my PC
  2. What actually happened or you actually saw:
    Just before the logon-screen the monitor went black and the HDD spinned-up again, just like when doing a hard reset.
  3. What you expected to happen or see:
    The logon screen? :wink:
  4. How you tried to fix it & what happened:
    I checked several hardware componenents, including RAM, CPU, Motherboard and the HDD. No errors whatsoever.
  5. If a software compatibility problem have you tried the compatibility fixes (link in format)?:
  6. Details & exact version of any software (execpt CIS) involved (with download link unless malware):
    None.
  7. Whether you can make the problem happen again, and if so precise steps to make it happen:
    The problem can be easily triggered again by activating the “Enhanced Protection”- feature. Disabling the feature stops the BSODs. This works on a freshly installed Windows 7 x64 + Comodo, with nothing else installed, except drivers.
  8. Any other information (eg your guess regarding the cause, with reasons):
    None.

B. FILES APPENDED. (Please zip unless screenshots).:

  1. Screenshots of the Defense plus Active Processes List (Required for all issues):
    The configuration is exactly the same as when the error occured, but the OS and all programs have been re-installed.


http://img191.imageshack.us/img191/4899/processess.th.jpg

Edit by Dennis2: I removed the spam like notification that your image were uploaded to a well known image sharing site

  1. Screenshots illustrating the bug:
    None

  2. Screenshots of related CIS event logs:
    None available, since I had to reinstall everything

  3. A CIS config report or file:
    https://rapidshare.com/files/4091292111/Config.zip

  4. Crash or freeze dump file:
    4 Windows Dump Files that were created after the BSODs:
    https://rapidshare.com/files/28241704/Comodo_dumpfiles.zip
    I don’t know if Rapidshare is ok for this, please let me know if you need me to upload those somewhere else.

  5. Screenshot of More~About page. Can be used instead of typed product and AV database version:

C. YOUR SETUP:

  1. CIS version, AV database version & configuration:
    CIS 5.8.213334.2131, AV feature not installed (Avast)
  2. a) Have you updated (without uninstall) from a previous version of CIS:
    Yes .
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: Yes.
  3. a) Have you imported a config from a previous version of CIS:
    No.
    b) if so, have U tried a standard config (without losing settings - if not please do)?: —
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):
    No
  5. Defense+, Sandbox, Firewall & AV security levels:
    Defense+=Safe Mode, Firewall=Custom Policy, Sandbox on
  6. OS version, service pack, number of bits, UAC setting, & account type:
    Windows 7 x64 Pro SP1, UAC enabled, 1 Admin & 1 User Account
  7. Other security and utility software currently installed:
    Avast Free Antivirus 6.0.1367 (installed without the “Behaviour Analysis”-feature.)
  8. Other security software previously installed at any time since Windows was last installed:
    None.
  9. Virtual machine used (Please do NOT use Virtual box)[color=blue]:
    No

If I missed anything important, please let me know.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Moved to Verified.

Many thanks again

Dennis