BSOD When Enabling Fully Virtualized

Let me also add a BSOD report, but mine is a little different, and kind of reproducible.

First off, I’ve been running every version of v6.x since it came out, and have not had any problems. I even updated to very latest 6.2 version and had no problems. I then read on the forum that the latest update introduced an “Advanced View” and “Fully Virtualized” sandbox method.

I then activated those two options, and, it, seemed, all was well.

This was on TWO different Win 7 32bit installs - fully updated.

Both computers produced a BSOD with the error being in NTFS.sys - sometime during the night. I awoke and saw them (these machines have never BSOD’d before). I thought that this was odd, but figured “stuff happens” and rebooted with a chkdsk on eash volume. Both computers came back up, and I used each for a while and didn’t notice any problems. I went to run an errand and was gone for about 30 minutes. I came home and the upstairs PC had a BSOD with NTFS.sys. The downstairs PC was fine…but later in the evening, it too showed a BSOD with NTFS.sys.

I then uninstalled Comodo completely, and let both computers sit for two days - NO BSOD.

I then re-installed the latest Comodo, but didn’t activate “Advanced View” and the Sanbox setting just said “Enabled” (No choices, the default). - NO BSOD

I then re-activated “Advanced View” and this time set the sandbox to ANYTHING BUT “Fully Virtualized” (I like “Untrusted”) - NO BSOD

I think “Fully Virtualized” is causing BSODS with NTFS.sys after sitting idle for a while.

I have no dumps, as I don’t have my computer set up to make them. I also tried to use your “form”, but it is a little confusing to me, hopefully this info is good enough. These are production machines, so I don’t want to make them BSOD again to test, sorry.

One last thing I noticed - the network icon (NIC Adapter) “comes online” almost instantly without Comodo (and even with, on prior versions IIRC), but on the latest 6.2, I have a blue spinning icon on it for 2-3 minutes. I confirmed this when I uninstalled as listed above.

Thanks, hope this helps.

I split this into its own topic, as it appears it may have a different cause. I also gave it a more fitting title. Please let me know if you believe the title adequately summarizes the issue.

However, please switch your computer to create full dumps, and see if you can reproduce this. That is the most important thing. A full dump should contain nearly all information the devs will require in order to understand what is causing this.

However, I do need for you to create a formatted report in order for me to forward this to the devs. The format can be found here. Just copy the code and paste it into your reply. Then fill out your answers after each colon. Use preview to see what the final product will look like. I can definitely help you with any questions, or trouble, you have.

However, the most important thing is to get a full dump after the BSOD occurs. Please upload it to this page and paste the download link in your response.

I am definitely willing to work with you to figure this out, and get this submitted. BSOD’s are very serious and are also fixed quickly by the devs.

Thank you.

All the changes are fine, thanks. I’ll see what I can do - I definitely can’t use my HTPC to get the dump from…no way - the wife likes TV, LOL. The downstairs one may be possible.


Thanks, getting a full dump is the surest way to make sure this gets fixed. It’s very important.

Thank you.

PM sent.

Well, I’m at a loss now - I enabled Fully Virtualized on the downstairs computer, and it hasn’t BSOD’d yet. But on the upstairs HTPC, after 4 days, it just BSOD’d twice in a row, a few minutes apart…but remember, I disabled FV on the HTPC, so that can’t be it.

Both machines are on OCZ Vertex SSD’s, a v2 and v3. I wonder if the SSD is going bad? It still would be a huge coincidence that both would do so around the same time though.

So maybe it isn’t Comodo, and is another piece of software? (I run a lot of the same things on both computers).

This weekend I’m going to re-do the HTPC with a new Samsung SSD and Win7 64bit…if it happens on that build, I’ll report back, but for now, I don’t think I can add anything else to this thread.


You could try entirely disabling CIS on both computers entirely and seeing if the issue still occurs. If not then it may still be due to Comodo. In that case a Full Dump will enable the devs to figure out what’s going on, even if you haven’t been able to narrow down the cause.


Yeah, I’d have to run the Windows firewall and maybe MSE or Avast for protection, but that may work. Here’s the problem with full dumps though: I set up my computers to have very minimal OS partitions. A full dump requires the page file to be bigger than the RAM correct? I don’t have enough room on C:\ for that. I had it set up that way before doing some reading on dumps, but the BSOD said “Not enough room…starting Mini-dump…” But it didn’t do that either. I went back and set it to Mini-Dump in the Windows Advanced settings and am waiting for it to happen again.

Understood. In that case we’ll just have to use a Mini-Dump. Please let me know if it reproduces with CF uninstalled.

Thank you.

Any update on this?

I wiped out the upstairs computer, replaced the OCZ Vertex 3 with a Samsung 840, re-installed Windows, switching from W7 32bit to W7 64bit. Installed the latest version of Comodo, which updated once to an even newer version, enabled Proactive/Advanced/Fully Virtualized this morning, and so far, no problems, other than the network adapter taking forever to ‘come online’. I get a blue spinning circle over the adapter tray icon for like 2-3 minutes. It was the same on 32 bit. Nothing on the downstairs computer either, nor a 64bit laptop I left running for a few days as a test. Must have been a local problem, but I will keep you updated if anything happens.


Okay, I’m glad to hear nothing’s happened so far. Please let me know if it does.


Okay, at this time I’ll go ahead and move this to Resolved. Please let me know if the BSOD recurs.

Thank you.