BSOD when computer unused for > 1 hour [305]

TOPIC TITLE
Random BSOD
If stay idle for an hour or more, it reboot randomly, but never when i work on it.Restarting after a BSOD is set on, so i couldnt saw any message until a few days ago when i found a view BSOD message program.Using it i saw that cmdguard.sys is mentioned.Other posts about random BSOD didnt inspired me about a solution so i decided to make this one.

The bug/issue

  1. What you did: Every time I left PC for an hour or more it encounter at least an BSOD and reboot
  2. What actually happened or you actually saw: I saw it restarted when i came back
  3. What you expected to happen or see: I expected to be as i left it
  4. How you tried to fix it & what happened: I tried nothing yet; waiting for your suggestions
  5. If its an application compatibility problem have you tried the application fixes?:I didnt knew it was cmdguard.sys until i saw the minidump content a few days ago
  6. Details (exact version) of any application involved with download link: At this time, the last Comodo firewall
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: just let it unused, because when i use it everything is ok (mean no crash during activity, only in idle)
  8. Any other information (eg your guess regarding the cause, with reasons) : not a clue

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug:
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:
  3. A CIS config report or file.
  4. Crash or freeze dump file: My whole collection of minidumps

Your set-up

  1. CIS version, AV database version & configuration used: 5.0.163652.1142- default, Avira 10.0.0.567 free, almost default.
  2. a) Have you updated (without uninstall) from CIS 3 or 4, if so b) have you tried reinstalling?: Yes;not yet
  3. a) Have you imported a config from a previous version of CIS, if so b) have U tried a preset config?:dont know what was imported, just updated from 4 to 5
  4. Other major changes to the default config (eg ticked ‘block all unknown requests’, other egs here. ) No
  5. Defense+ and Sandbox OR Firewall security level:Defense+Firewall=safe mode, sandbox disabled
  6. OS version, service pack, no of bits, UAC setting, & account type:Winxp,sp3,32,default, administrator
  7. Other security and utility software installed: ccleaner, mydefrag
  8. Virtual machine used (Please do NOT use Virtual box):None

[attachment deleted by admin]

Thanks for a thorough issue report.

Please try the following in sequence:

  • is mydefrag set to defrag when idle or at the time the problem occurs, if so please unset this
  • is your computer set to suspend or hibernate, if so please unset this and see if the problem recurs
  • uninstall Avira (backing up settings first) and see if problem still happens
  • do a clean re-install of CIS using process here, and see if problem still occurs

Best wishes

Mouse

There is sufficient information for this type of report, so I am forwarding to format verified. If you could add the information requested later that will help devs to resolve the issue.

Best wishes

Mouse

Well… yes, Mydefrag was set to defrag in idle, but the crash doesnt appear at the begining.Anyway, I disabled it on idle.
Strange is that it defrag zone1-4, which include the directories,Windows files, booting files and regular files areas, but crash every time a few percents after begining movements on the 5-th zone (the most rarely used files).
That may suggest some local issues, rather then a system or apps conflict.
Still dont know what’s happening, but i’ll try some more tests.
Never used suspend or hibernate.
Uninstaling Avira and clean reinstal of CIS, I’ll consider them as last to try.
I’ll be gratefull for any ideea about solving Mydefrag unknown problem

Best regards

OK, thanks for offering to do additional tests. As this is a BSOD I’ll add to Bugzilla anyway.

The most obvious thing for Mydefrag to conflict with is the real time or batch AV scanner (in CIS and Avira). Otherwise, in case MyDefrag does not ask properly for unlimited access, you could try making Mydefrag an installer/updater in CIS D+ rules - dunno if Avira has something similar. You need to work out how Mydefrag works to do all this - maybe a service or driver needs attention as well as the GUI.

Otherwise installation problems and three way conflcits with Avira are a likely source.

Hope this helps

Mike

hi adyb,
you appear to be right comodo file system driver cmdguard has also cause BSOD on my system while running chkdsk and defraging the disk.

but since it was random not reproducible hence not reported.

adi