bsod when closing sandboxed firefox 4 beta 8 [NBZ]

The bug/issue

  1. What you did: i upgraded firefox 4 beta to 8.
  2. What actually happened or you actually saw:when i closed firefox i got bsod.
  3. What you expected to happen or see:normally close firefox ?!
  4. How you tried to fix it & what happened:clean installations of firefox 4 beta 8 and cis,only thing that solved the problem was to cancel filesystem and registry virtualization in the advanced menu of the permanet sandboxed apps>firefox
  5. If its an application compatibility problem have you tried the application fixes here?:i tried what i mentioned above,beta 7 worked fine.
  6. Details (exact version) of any application involved with download link: i dont understand this q
  7. Whether you can make the problem happen again, and if so exact steps to make it happen:put firefox 4 beta 8 as permanently sandboxed and partially limited.
  8. Any other information (eg your guess regarding the cause, with reasons):maybe the new hardware acceleration introduced to this version of the beta.

Files appended. (Please zip unless screenshots).
didnt manage to insert files to message body so i attached them.

  1. Screenshots illustrating the bug:
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:
  3. A CIS config report or file.
  4. Crash or freeze dump file:

Your set-up

  1. CIS version, AV database version & configuration used: comodo firewall with defence+ both on safe mode,no antivirus - version 5.0.163652.1142
  2. a) Have you updated (without uninstall) from CIS 3 or 4:no - clean installation.
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS: no.
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):no
  5. Defense+, Sandbox, Firewall & AV security levels: D+=safe mode , Sandbox=enabled , Firewall =safe mode , AV = not installed.
  6. OS version, service pack, number of bits, UAC setting, & account type:win7 ultimate 32bit,uac-default,regular user account-not admin.
  7. Other security and utility software installed:antivir 10 + threatfire.
  8. Virtual machine used (Please do NOT use Virtual box):actuallaptop not a virtual machine.

hope i gave all the relevant info,
no comodo log available because system crashes immediatly.

[attachment deleted by admin]

Thank you for your bug report in the required format.

Moved to verified.

Thank you

Dennis

thanx dennis
i have a question-
will i get an answer or a solution in this thread,if not,where can i expect to find it?

Sorry all I know is, if any more info is needed they will post in this Topic or ask you by PM.

Dennis

followup:
firefox 4 was released ,the problem i mentioned still persists.
nothing changed from the original post.
has anyone had that problem ?

HAL crashes are hardware related, so check FF4’s hardware acceleration option, try to turn it of and see it that solves your issue.

already tried that,didnt help
thanx mineria, :frowning:

Try updating your graphics card drivers to the latest available version. Does that help?

i have the latest driver,thats not the problem.
as i mentioned in my original post,something changed in ff 4 beta from 7 to 8,im not sure what it is,but ff 4 beta 7 worked fine with filesystem and registry virtualization and ff 4 beta 8 and all versions after including the final release caused the bsod when i close ff session.
i tried that on a virtual machine as well to exclude the option that something in my system is the cause,it happend again and again.

When it is not related to graphics drivers then I rest my case.