BSOD in Win 8 Pro caused by Starting Kiosk [+DUMP] [M389] [v6]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?: No, it’s a one off
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    a. Started Kiosk from the widget
    b. Computer crashed with error: (0x000000f7 DRIVER_OVERRAN_STACK_BUFFER)
  • If not obvious, what U expected to happen: Not applicable
  • If a software compatibility problem have U tried the conflict FAQ?: Not applicable
  • Any software except CIS/OS involved? If so - name, & exact version: Not applicable
  • Any other information, eg your guess at the cause, how U tried to fix it etc: None
  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware)
    [/ol]

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: 6.1.276867.2813

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: BB (Restricted), D+ (Safe Mode), AV and Firewall (Safe Mode). Running Running Proactive Security.
  • Have U made any other changes to the default config? (egs here.): Firewall is set to Stealth rather than the default setting of stealthing ports on a per case basis. I have ARP cache filtering enabled. No changes to default Sandbox, HIPS or BB settings.
  • Have U updated (without uninstall) from a CIS 5?: No
    [li]if so, have U tried a a clean reinstall - if not please do?: Not applicable
    [/li]- Have U imported a config from a previous version of CIS: No
    [li]if so, have U tried a standard config - if not please do: Not applicable
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used: Windows 8 Professional x86, UAC disabled, administrator account
  • Other security/s’box software a) currently installed b) installed since OS: a=
    b= Hitman Pro , Malwarebytes Antimalware Free and Super Antispyware Free; all on demand only.
    [/ol]

[attachment deleted by admin]

Thanks for an excellent bug report Eric.

Could I just check whether you have made any major changes to the default config (B.3)

Also are any of these security programs currently installed? (B.7) (a)

Best wishes

Mouse

No major changes to the Proactive Security. I have enabled “Enable adaptive mode under low system resources” and “Enable enhanced protection mode” and disabled “Block all unknown requests if the application is closed”. But they are standard I think.

Firewall is set to Stealth rather than the default setting of stealthing ports on a per case basis. I have ARP cache filtering enabled.

No changes to default Sandbox or BB settings.

Which things are worth adding?

Also are any of these security programs currently installed? (B.7) (a)

Best wishes

Mouse

They’re all on demand only. I will add that

Just to check, was this a BSOD, Eric? And all you did was start Kiosk (using what button?), no other messages (eg request to install Silverlight?).

Editing your report with new info - hope that’s OK

Best wishes

Mouse

I started from the widget. Silverlight and Dragon are installed so no messages that they are not present. Editing is cool with me.

I added to the report that I started Kiosk from the widget.

Thanks Eric

Finally just to clarify, this is a BSOD, is it, ie you get a character-based screen, a ‘creating dump’ count-down, and the machine re-starts?

Just to save me opening up the debugger!

It rebooted and I got the new type blue screen of Windows 8. It says something along the lines of oops we found and error; we’re now creating a report…bla bla…

I checked the dmp file with Blue Screen View from Nirsoft to see the details. It showed the problem was with cmdguard.sys.

I think that’s a BSOD, amended title accordingly. Problem tracked.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again

Mouse

Can you please check and see if this is fixed with the newest version (6.2.282872.2847)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

I tried starting and closing Kiosk 20 times and it did not crash. I would say it is fixed.

Thanks for checking.

I’ll move this to Resolved.