BSOD If Any Key Hit While Computer Is Sleeping [M1126]

A. THE BUG/ISSUE (Varies from issue to issue)
Can U reproduce the problem & if so how reliably?:
Yes, almost every time.
If U can, exact steps to reproduce. If not, exactly what U did & what happened:
1: I turn my pc to “sleep”
2: Then, after it’s sleeping, I press any key on the keyboard.
3: If CIS is installed I see the desktop for less then a second then there is a BSOD and the computer crashed.
One or two sentences explaining what actually happened:
If CIS is installed, and the computer is put to sleep, there will be a BSOD if a key is pressed on the keyboard while it is sleeping. If CIS is removed there is no BSOD. However, the crash doesn’t happen all the time. Sometimes the computer responds normally, and once it just froze, but didn’t BSOD. However, most of the time BSOD does show up.
One or two sentences explaining what you expected to happen:
Hitting a key on the keyboard while the computer is sleeping should not cause a BSOD.
If a software compatibility problem have you tried the conflict FAQ?:
NA
Any software except CIS/OS involved? If so - name, & exact version:
Only CIS was involved.
Any other information, eg your guess at the cause, how U tried to fix it etc:
I have a fairly long history of crashes with this pc, i took it to a place and they told me the issue is with the hard disk, i replaced it and now this computer crash again… According to the crash report it is because of cmdhlp.sys + 3e7b and the “crash address” is: ntoskrnl.exe+7929f. I attached the CIS report and the Windows crash report, i need to know if the issue is CIS or another part of the pc, i suspect the RAM sticks but i cant be sure.
The Complete Memory Dump can be downloaded from this page:
http://www.myupload.dk/showfile/c4wnli.zip

B. YOUR SETUP
Exact CIS version & configuration:
CIS 7.0.317799.4142 , VIRUS SCOPE v7.0.5.33.15.4132
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Auto sandbox on OFF, firewall on Safe mod, AV on “stateful”
Have U made any other changes to the default config? (egs here.):
Enabled virusscope and disabled Auto-Sandbox
Have U updated (without uninstall) from CIS 5 or CIS6?:
NO
if so, have U tried a a a clean reinstall - if not please do?:
NO
Have U imported a config from a previous version of CIS:
NO
if so, have U tried a standard config - if not please do:
NO
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 7 64bit Administrator, UAC on default
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=Malwarebytes with the trial version disabled b=None

[attachment deleted by admin]

is anyone going to replay?

I’m sorry for not replying sooner. Things have been incrediby busy in my personal life and it has made it impossible to log on until now. I hope you understand.

As for this issue, please configure your computer to create a Complete Dump File in case of a BSOD. Instructions on how to do that are on this page. Please do this regardless of whether you believe it will happen again. This is very important as in the vast majority of cases a Complete Dump is required in order for the devs to identify the issue.

Now, you said that this was not reproducible. Has it happened since the first time. Also, after configuring your computer to create the Complete Dump please do see if you can replicate this. From previous experience a Complete Dump is essential for the devs to identify the issue, although I can forward it with just the Minidump. The problem is that with a Minidump there is likely nothing they can do. At least that has been the case in the past.

Let me know what you find.

Thanks.

sorry if i am impassioant, this computer just drives me crazy…

anyway i can reproduce this bug simply by making my pc go to “sleep” mod then pressing the keyboard., i tried doing this after uninstalling comodo and it didnt happen, when i reinstalled comodo it happens again ( I turned off auto sandboxing and set some unrecognized files to “trust”) before trying it.

but i cant configure the computer to create a Complete Dump File, the computer just doesn’t show that option in the drop down menu under “system faliure” only “kernel memory dump” and “small memory dump”

Did you follow the advice under the section labeled “If the Complete memory dump variant is unavailable in the Write debugging information section, perform the following actions:”? If not, please do.

Thanks.

yea i saw the rest of the instruction shortly after i commented, im flowing them now

ok i have the file now, it seems to be too big to upload though the forum even after compressing it to a zip file (its 2 gb), ill change my max memory back now

Sorry, I should have mentioned this. It is expected that the file is very large. Please do put it in a zip file. Then upload that zip file to a file sharing site and post the download link in your next reply. If you would like any suggestions about services to use please feel free to ask.

Thanks.

here we go: (Moved by Chiron to http://www.myupload.dk/showfile/c4wnli.zip )

took a while to upload

Thank you. I took that and uploaded it to a third-party service so you wouldn’t have to worry about keeping the file. If you like you can remove it from the Google drive. It’s up to you.

I also edited the first post. Please look it over and let me know if everything looks correct.
Also, I noticed that you didn’t answer one of the questions. Please let me know of which anti-malware products used to be installed on your system, but are now removed.

Thank you.

Thanks for uploading the file, ill remove the link.
I also answered the question about security products, this OS was installed only a few months ago and the only security product i installed apart of Comodo is Malwarebytes that i use only to scan files i recently downloaded from the internet, normaly it is not run in the background. Your editing of my answers are fine, I just want to add that apparently the crash doesn’t happen all the time, i just notice that sometimes the computer responds normally, and once it just froze and didnt react. but most of the time BSD does show up.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time, availability, and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

um can you suggest even a temporary fix if possible? or if the cause is found and what it is? of course after all the testing…

I kinde like this antivirus and i don’t want to install a different one…

I’m sorry, but I am just a volunteer Moderator. I don’t have any insight into what may, ultimately, be causing this. Obviously, it seems that disabling Sleep Mode would be a workaround, but that may not be preferable to you. Other than that I would recommend trying to disable different components, and see if perhaps it is a certain component (such as the antivirus) which is causing this.

Sorry.

Hello jbustter,

Can you please replace attached cmdhlp.sys to %windir%\system32\drivers and try again?
it is for win7x64 only
Thank you.

Regards
Haibo

[attachment deleted by admin]

i think the crash happens only when cmdhlp prosses exsists, am i correct? ill try using the attached file

how can i make syre cmdhlp prosses run before i put my computer to sleep?

sorry for triple posting, but now i fear that maybe my firewall isnt working, cmdhlp is not showing up in the process list even after replacing it with the file you gave me and restarting, i also tried comodo leak test with the firewall on and off and got the same results at both tests (Comodo Firewall | Get Best Personal Firewall Software for $29.99 A Year) (I attached the log file) , the UI and diagnostics show no issues like the firewall is up and running…

as i said before, I think my ram sticks are at a bad condition and i intend to replace them in the next few days, if that could be the cause to those issues.

[attachment deleted by admin]

Hi, cmdhlp is a driver, not process.
you can check it by running “sc query cmdhlp” in cmd. State should be RUNNING.
Just replace it, reboot and try.
Thanks

Regards
Haibo

thank you, i didnt have blue screen for a few days now, and it didnt seem to return, although i didnt manage to reproduce it for some reason, I replaced the cmdhlp.sys file anyways. I will return to you if this issue seem to come back later.