[BSoD] CIS: Inspect.sys DRIVER_IRQL_NOT_LESS_OR_EQUAL [Dump File attached]

The bug/issue
1. What you did: I browsed the internet using Forefox, had some other network programs running in background.
2. What actually happened or you actually saw: Suddenly the screen went black, the HDD clicked and spinned down, and the stop error showed up on my screen.
3. What you expected to happen or see: Nothing.
4. How you tried to fix it & what happened: I updated the NIC driver in the device manager from a 2003 version to 25.2.2008. Problems persist.
5. If its an application compatibility problem have you tried the application fixes here?: N/A
6. Details & exact version of any application (execpt CIS) involved with download link: Firefox 4.01 (www.mozilla.com), Bitcoin 0.3.21 (http://www.bitcoin.org/)
7. Whether you can make the problem happen again, and if so exact steps to make it happen: It happens seldomly and seems to be triggered randomly.
8. Any other information (eg your guess regarding the cause, with reasons): See additional info below.

Files appended. (Please zip unless screenshots).
1. Screenshots illustrating the bug: N/A
2. Screenshots of related CIS event logs and the Defense+ Active Processes List: N/A
3. A CIS config report or file: Included.
4. Crash or freeze dump file: Included.

Your set-up
1. CIS version, AV database version & configuration used: CIS: 5.4.189822.1355, AV signature: 8772
2. a) Have you updated (without uninstall) from CIS 3 or 4: No, fresh OS install.
b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: N/A
3. a) Have you imported a config from a previous version of CIS: No.
b) if so, have U tried a standard config (without losing settings - if not please do)?: N/A
4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): I set CIS to alert me for all network activities (custom policy).
5. Defense+, Sandbox, Firewall & AV security levels: D+= Safe Mode, Sandbox= Disabled, Firewall = Custom Policy, AV = Stateful
6. OS version, service pack, number of bits, UAC setting, & account type: Windows XP Pro SP3 32bit fully patched, admin account, DEP = Essential windows progs/services
7. Other security and utility software installed: Process Explorer, OllyDbg, WinDbg, TrueCrypt
8. Virtual machine used (Please do NOT use Virtual box): N/A

Additional info:
NIC: Realtek 8139/810x Family Fast Ethernet NIC
Driver: Realtek Semiconductor Corp.
Driver version: 5.687.225.2008

0x00000014 0x00000002 0x00000000 0xEB5BF13E

[attachment deleted by admin]

Thank you for your Issue report in the correct Format with needed files attached.

Moved to verified.

Thank you


Any updates on this?
Here’s another crash dump.

[attachment deleted by admin]