BSOD 0x77 while copying large files from DVD drive [NBZ]

CIS FSfilter interfering while copying large data from DVd

The bug/issue

  1. What you did: copied large data from DVd

  2. What actually happened or you actually saw: computer hanging,hdd changing to PIO mode and SATA controller error then BSOD

  3. What you expected to happen or see: Normal operation

  4. How you tried to fix it & what happened: chkdsk+ Uninstalling Sata controller + CIS diagonsitic.(it found problem in installation).

  5. If its an application compatibility problem have you tried the application fixes here?: n/a

  6. Details & exact version of any application (execpt CIS) involved with download link: n/a

  7. Whether you can make the problem happen again, and if so exact steps to make it happen: yes

    • when you try to copy large data from a SATA DVD drive (1.5G/s) to HDD(3.0G/s) problem repeats.
    • It does not repeats when you disable AV by running setup once again.
  8. Any other information (eg your guess regarding the cause, with reasons):

ya I have a very very wild guess CIS file scanner driver is responsible for this. My SATA DVD drive(1.5 G/s) is slower than Seagate HDD(3.0 G/s). this means my HDD should never be flooded with Data to choke it.
However controller error is lodged in system events.

   For large size file copy operation DMA is involved. when you look in system events you find a large No of   disk related error when this file copy operation is being carried out. while large file copy operation is
  active CIs  tries to gain access to disk files, thus interrupting the process ( causing condition similar to
  - there is one more reason to believe in this when you reduce the speed of DVd by magic speed this
    error does not crops up. means CIS SATA controller is not heavily loaded, question is who else is 
  gaining access to DISK (my opinion it is CIS). it is the slow operation of CIs causing this.

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: n/a
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:
  3. A CIS config report or file. N/a
  4. Crash or freeze dump file: attached ox77 dump in zip

Your set-up

  1. CIS version, AV database version & configuration used: 5.3175888.1277 VSDB 7448
  2. a) Have you updated (without uninstall) from CIS 3 or 4: No
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: No
  3. a) Have you imported a config from a previous version of CIS: NO
    b) if so, have U tried a standard config (without losing settings - if not please do)?: No
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): No
  5. Defense+, Sandbox, Firewall & AV security levels: D+= clean , Sandbox=Enabled , Firewall = Custom , AV = Stateful
  6. OS version, service pack, number of bits, UAC setting, & account type: xp sp3 32 bit,admin
  7. Other security and utility software installed: Not any
  8. Virtual machine used (Please do NOT use Virtual box): N/a

I have checked the H/W and all cabling, found no problem this does not happen if AV is disabled.



[attachment deleted by admin]

Thank you for your bug report in the required format.

Moved to verified.

Thank you