Browsers Blocked

Hello everyone :slight_smile: This is my first post here, sorry for it being a problem post.

============================================
Laptop,
Manufacturer: Gateway
Model Number: M-6337
Processor: Intel Pentium Duel CPU T2390

OS: Windows Vista Home Premium (32-bit)
Service Pack 1

Comodo Internet Security (Free)
Product Version: 3.10.102363.531
Virus Signature Database Version: 1157

============================================

The other week I updated/installed to the newest version of Safari (v4.0.2) onto my laptop. After I had installed it, it was unable to access the internet any more, I didn’t bother about it much at the time because I’ve have Safari working on my other computer.

The day before yesterday, I installed the newest version of Firefox (v3.5.1) and was unable to access it internet from it.

The first thing I did was to go to:
“Firewall → Advanced → Network Security Policy”
But all my browsers were set to “Treat as: Web Browser”…

I double-checked the file locations in the Firewall and they are identical to the installed locations.

Internet is on, TCP and UDP protocols both work fine, and my other browsers (Opera, Chrome, Netscape, IE7, Avant) still work just fine.

Next I tried re-installing Firefox into a different location, but it still will not connect.

After that I decided to reinstall the Comodo Firewall and see if that would fix it, so first I uninstalled CIS but it didn’t change anything. After installing CIS again, Firefox and Safari were still blocked.

I’m starting to think that the answer to the problem might lie somewhere inside the windows registry… I’d be willing to dig in with Regedit if I knew where to start looking.

Does Comodo edit the registry when blocking internet access to programs? What about when programs install? …Or maybe the problem isn’t from the firewall at all?

What you guys think?

Welcome to the forum Barrikor.

So everything works except fx and Safari?

You have checked there are no block rules that may obstruct these two?

Are you using D+?

Thanks for the welcome :slight_smile:

So everything works except fx and Safari?

Actualy, I just noticed that Chrome and IE aren’t accessing the internet either… Maybe/probably the same problem, but I don’t want to jump too fast…

But as far as I can tell, Opera, Netscape, Flock, K-Meleon, Avant, and AOL Explorer, all load fine.

You have checked there are no block rules that may obstruct these two?

I think I’ve checked everything, (I’d be glad to be wrong though).

There are no Firefox or Safari related files in either “Antivirus → Quarantined Items” or “Defense+ → My Blocked Files”

The rules for Firefox and Safari inside “Firewall → Advanced → Network Security Policy” are as followes:

http://img129.imageshack.us/img129/1091/firewallrules03.jpg

Are you using D+?

I think so…

http://img200.imageshack.us/img200/3185/firewalldefenseplus01.jpg

There’s a chance it could just be malware, but with it coinsiding with the instalation…

Is your installation of CIS a clean install or did you upgrade from a previous version? Can you show us a screenshot of the Firewall logs of around the time you fire up the browsers that don’t work? They can be found under Firewall → Common Tasks → View Firewall Events.

What rules do you have set for the non functioning browsers in Defense +?

Do you use proxy??? Most of the programs configure themselves to use IE proxy. So, if IE is configured to use proxy programs like antivirus updates, MBM etc. should work ( I am not sure about browsers like Netscape or Opera for this).

Please open

IE>Tools>Internet Options>Connections - LAN settings and Settings

and see if there is any entry for proxy there… If yes, copy the same in Firefox and see whether it connects.

I don’t actually know what version I had before the reinstall, (it would be whatever the latest version was around 5 months ago…) The current version I have is “3.10.102363.531”.

On the reinstallation, I first un-installed, then re-installed.

Can you show us a screenshot of the Firewall logs of around the time you fire up the browsers that don't work? They can be found under Firewall --> Common Tasks --> View Firewall Events.

Here it is, I resized the grid rows a bit to make it show better…
:


http://img11.imageshack.us/img11/9273/firewallevents01.th.jpg

What rules do you have set for the non functioning browsers in Defense +?

They all are set as “Custom policy”…

When I right click and hit “Edit…” and then “Access Rights”, this is the same for all of them:


http://img24.imageshack.us/img24/8776/firewallpar01.th.jpg

IE7:

http://img17.imageshack.us/img17/3757/ieproxysettings.jpg

FF3.5:

http://img269.imageshack.us/img269/6001/firefoxproxysettings.jpg

Unfortunately, the log file doesn’t show any browser entries, do you have any in the log?

Incidentally, you appear to be blocking svchost.exe from obtaining an IP address via DHCP, is this for a reason?

[attachment deleted by admin]

Happened to me several times. If you have you configuration saved, reload it via 'Manage My Configurations ’ ‘Import’, then browse for the file c:\program files\comodo<firewall folder>, select it and click ok and be patient, this takes a while. A popup will confirm the success of the import. Then click on the Opimum Security bar in ‘My Configurations’ and click activate even if it says active. Click ok.
If you don’t have a saved configuratin you could still try re-activating Optimum Security.
This resolved my issues with Opera and Firefox not connecting while only the email client would still be able to connect.