Border for FV programs is on the wrong screen if window is maximized [V6][M384]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?: I think so, at least on my system. This also happens, even after reinstalling Windows 8.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
  1. Set up two monitors
  2. Define a primary monitor
  3. Open something as Fully Virtualized and make sure it has the green border, a web browser is what I’ve used for the test.
  4. Maximize the program in the non-primary monitor.
  5. The green box will now be on the primary monitor and not on the secondary monitor.

I’ve attached a screenshot which shows the issue.

I would normally check for other bug reports mentioning the same thing but I haven’t had time to make any extensive look so if this has already been reported then the topic can be removed.

  • If not obvious, what U expected to happen: The green border to be around the program and not the wrong monitor.
  • If a software compatibility problem have U tried the conflict FAQ?: Me no think so.
  • Any software except CIS/OS involved? If so - name, & exact version: Nope, well the programs run as fully virtualized but otherwise neigh.
  • Any other information, eg your guess at the cause, how U tried to fix it etc: My guess is that if the the application is maximized then the border to set to a very specific location, I guess the developers never thought that people might use two screens as a maximized application on one screen always can have a fixed border that doesn’t need to be dynamic after the actual program, so while the program isn’t maximized the border will follow the program though when it’s maximized the border will set to a fixed position, my guess and not actually proven in any way.
  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware)

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: 6.1.275152.2801 - Proactive security.

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: All enabled, HIPS set to Safe, BB set to FV, firewall set to custom.
  • Have U made any other changes to the default config? (egs here.): Yes, too many to remember which were not default and too many to mention.
  • Have U updated (without uninstall) from a CIS 5?: No.
    [li]if so, have U tried a a clean reinstall - if not please do?:
    [/li]- Have U imported a config from a previous version of CIS: No.
    [li]if so, have U tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used: Windows 8 64-bit, UAC off, Administrator account.
  • Other security/s’box software a) currently installed b) installed since OS: a=Zemana AntiLogger Free b=Zemana AntiLogger Free

[attachment deleted by admin]

Hi Sanya

Thanks very much for your report.

Your are an old hand here so I won’t give you the standard response.

Could you just check through your nug report to make sure you have ansered all the sub-parts of all questions and appended the standard files? It’s a sort of hybrid issue with virtualisation and GUI involved so we’ll need all the normal stuff I think. Could the active process lis show the process instances involved please, just in case Killswitch is getting confused too?

Thanks very much in anticipation.

Best wishes


Sorry mouse1, I won’t be able to give this for atleast 30 days, probably more. I’m sorry I forgot that information, I did the bug report in a rush since I wouldn’t have access to my computer for 30 days after that, at least 30 days.

OK I can move to non-format meanwhile. You can post it when you get back. No probs.

30 days you on holiday? That’s some holiday :slight_smile:

Far from holiday, Going last year in high-school and now out on practice but I couldn’t find something relevant to my program so I have to practice at my dad’s job which is a bit away so I have to stay with him out on the country… Honestly school is more of a holiday than this. Though I’ve been given permission to study when there isn’t much to do.

Just think of all that lovely country scenery :slight_smile:

OK will move meanwhile.

Best wishes


My sincere apology for forgetting to come back and fix the missing information, was supposed to do this in the beginning of June and now it’s middle of June.

I’ve added the killswitch current view and CIS diagnostics.

You may be interested in the fact that I’ve completely re-installed Windows 8 and the issue is still present after re-installation.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Not fixed in 6.2.282872.2847

Thank you for checking this.

I have updated the tracker.

Not fixed in CIS Version 6.2.285401.2860

Thanks for checking this. I’ve updated the tracker.

The devs have flagged this as fixed. Thus, I will move this to Resolved.

Please let me know if you are still experiencing the issue.

Thank you.

This is still not resolved in CIS 6.3.294583.2937 see screenshot (left is non-sandboxed CD right is sandboxed IE)

[attachment deleted by admin]

I’m sorry for this. In that case I will move this back to format verified and update the tracker.

Thank you for bringing this to my attention.

Not fixed in CIS version 6.3.302093.2976

Thanks for checking this.

I’ve updated the tracker.

Fixed in CIS 7.0.308911.4080 BETA

Thank you for checking this. As it is now fixed I will move this to Resolved.

Thanks again.