BOINC - firewall blocking, connected with loopback


i’ve installed BOINC today (the grid computing software used for Seti and other projects)
basically it consists of 2 applications boinc.exe, which is the client and boincmgr.exe, which is the manager where you can add projects, edit settings and so on. when i installed BOINC comodo asked me for permissions and i marked both applications as trusted applications.
they work together in such a way that when the manager is started, it starts the client as well in the background and the manager has to connect to the client - this is done by choosing a name of the computer as localhost, so basically it is a connection within the computer itself. and the manager won’t connect to the localhost at all.
the problem is comodo firewall for sure, cause when i disable it (even with defense+ enabled) BOINC connects without any problem.
i tried adding rules that would allow both applications for everything, but comodo just doesn’t listen.
i found this guide ( ) that explains in detail the way in which the manager connects to the client using loopback and i tried to set it in comodo, but it seems i can’t…

and now my request - could someone please read the guide in the link above and tell me what rules to set so that this loopback thing would work properly?
i’ve wasted half a day on this already and nothing works…


hello hunkydoris.
Does it works if you switch off the firewall for a sec?

If not then the problem is not with the comodo firewall.

when i turn off the firewall everything is working fine, the manager connects to the client and i can add projects and so on. so the firewall is definitely the problem here.

Hm, Have you got any global rules?
check Firewall> Advanced > Network Security Policy > Global rules

If so, how do they read?

Also check Firewall> Advanced > Network Security Policy > Application Rules
You have both boincmanager.exe and boinc.exe set as trusted if I got you correctly… but please double check.

It says Allow all on both those applications (without any extra stuff added)?
And still won’t work? ??? ???

my global rules look like this

and i’m sure u have the applications set as trusted - “allow all incoming and outgoing requests”

hrm, this seems out of my scoop.
Hopefully ronny or some other network technician will post, as I can’t help. :-\
You can bump the thread later if you are unable to solve it, and get no responses.
Anyway, good luck. :-TU :-TU :slight_smile:

You can add the Loopback zone as a trusted network zone. I think it is already defined under My Network Zones.

Now run the Stealth Ports Wizard and choose “Define a new trusted network stealth my ports to EVERYONE else” → Next → I would like to trust an existing My Network Zone → Choose the Loopback zone from the dropdown menu behind Zone Name → Finish.

i did what you wrote and it didn’t help.
then i noticed what rules the system has in the firewall and they’re “Allow system to send requests if the target is in loopback zone” and “Allow system to receive requests if the sender is in loopback zone”, so i created these rules for my 2 problematic applications and now it looks like this:

but it doesn’t work either…
i have no idea what else to do… :frowning:

Go to “Firewall” - “Firewall Behavior Settings” - “Advanced” - and then deselect “Block fragmented IP datagrams” this is what worked for me to get BOINC going…

The rules for BOINC are pretty straight forward, just two rules for the main programs and two for the support (screen-saver) programs, if used. No inbound rules are required.

See attached for details:

[attachment deleted by admin]