BOClean Missing Module

I have XP and have been running BOClean 4.26 with no problems. Today it started giving a message of Missing module can’t find BOC4UPD.EXE After reading some of the previous posting I shut down Comodo fireall pro and my anti-virus. Still got the message. I uninstalled and re-installed still the same message. Help Please.

I tried XP system restore/ one day back and on the reboot I got a new message. BOC426.XVU was not found.Go to all programs / Comodo BOClean/Updater . After I did this all worked well. Hope this helps someone. I’m working OK. Thanks.

I seemed to have gotten a simular issue this morning… Running the updater Manually with BoClean Closed (Shutdown) did the trick.


Well, in case Kevin doesn’t get here for awhile, I’ll give you his synopsis…

That’s a little sarcastic fracTure and uncalled for. Kevin aims to make each release as ■■■■ near perfect as possible.


You are entitled to your opinion, of course, as am I. All perceived sarcasm aside, what I presented is a condensed version of what Kevin has said repeatedly on this error message. At least that is what jumps out at me… it’s not BOClean’s fault, it is some other security program causing the message.

Fair enough… Apologies for the sharp reply.

Has there been any information on a work-around to resolve the issue?


No workaround that I am aware of, Eric. I posted what worked for me. I got the error message when manually updating. I enabled autoupdating for awhile… don’t even know if it was long enough to have downloaded and installed a new update… then switched the setting back to manual updating and the error message has not appeared again. It was quite a persistent error message until I did that. But I see users getting the message with different operating systems and with different updating settings, so it appears quite varied in nature.

Good luck. :slight_smile:

Caused by server problems, and as indicated in a previous message, have recoded BOClean’s source so that the generic error message will be more specific in the future, listing multiple possibilities including “download server is hosed” or some such. :slight_smile:

Problem though was the result of transitioning BOClean from its historic, checksummed FTP download to an HTTP download where Microsoft’s WININET library fails to download that LAST packet, and then reports “all well” until BOClean tried to load the database, and it’s bad. SERVER guys have already cleaned up their act (this problem affected not just BOClean, but other COMODO updates for other products) and FIXED it … just so’s ya know. :slight_smile: