BOClean Locks Up in System Tray

I tried a search using IE7 and BOClean and no similar topic turned up. So I am hoping to find out if someone experienced the same problem with this new thread.

I recently installed IE7 on my XP Pro PC. Since then, I noticed my Boc424 systray stayed at GREEN color, as opposed to the normal status of BLUE light. When I right for the menu, it did pop up but it was not accessible (the mouse cursor turned into an hour glass with hovering over it) and it wouldn’t go away until I use taskmanager to end Boc424.exe

Anyone encountered similar issue? what should I do?



Oh yes, by the way, I have Avast 4, CPF2.4.18.184 and Spyware Terminator

I installed BOClean 4.24, but on executing, the icon locks
up in the system tray. It’s blue in color, but right-clicking it
turns it red.

Further right-clicking doesn’t bring up any menu at all, it
seems fully locked up.

This seems to be the case too with the earlier version,
after which I uninstalled it.

I have Bitdefender 9 and Spyware Terminator 1.9 resident.
I tried disabling all of Bitdefender’s running modules and
exiting it, as well as Spyware Terminator, but it was the same.

Don’t know if this is relevant but there is another thread

The two threads have now been merged!

Both of you are using Spyware Terminator and having problems with BOClean.

Hmm, possible conflict?

Thought I’d mention it.

Sounds like a conflict to me but as Mike noted, the more likely culprit is Spyware Terminator.
You may want to test this by uninstalling Spyware Terminator to see if it clears up.
I’m going to merge this with the other topic on “Lock Ups” and see if I can get one of the CBO team members to look in on these for confirmation.

No, I am sure Spyware Terminator is not the problem. I never had any conflicts, and lot of the boys over at Spyware Terminator use CBOClean as well.

Greetz, Red.

Sorry if slightly off topic, but someone the other day said they had a problem with BOClean after running a Spybot scan. Just done that and no problems.
Also running Spywareblaster with no conflicts either.

I am also running spyware terminator, comodo fw (the latest stable) with boclean, no issues here.

I don’t use the clam module of ST, perhaps that’s the difference?

I don’t use Clam antivirus in Spyware Terminator too.

I tried disabling ST’s shield, and exiting it from the system
tray too, but to no avail.

Have you tried uninstalling ST completely; disabling it may not be enough.

If that cures it there are plenty of other programs available without conflicts.

Worth a try.


You might try creating a restore point, & uninstalling Avast.That may be the problem.Just as a reference point, Avast & ZAP don’t get along together.Just a thought.SMILE! (:KWL) (L) :BNC :BNC

it didn’t have a problem with ST 1.8.x, I will say the only really “new” thing is the crawler tool bar, may be I will reinstall BO424, then disable/remove crawler toolbar and see what’s gonna happen… over the weekend! :THNK

Foxman, a recent topic about the Crawler Toolbar on Safer Networking Forums :

You can also choose the 3.33 MB version withought the Crawler Toolbar from here :

( I am sorry, but I didn’t post the direct download link because LM will kick my ■■■ than :stuck_out_tongue: )

Greetz, Red.

Spyware Terminator uninstalled.

BOClean still locks up, but the icon is now green.

Gee thanks Rednose, but I am afraid that won’t be necessary anymore.

I have reinstalled ST 1.9 with everything except the AV (I never did), but this time Bo424 behaved perfectly so far… will keep a tap on it .

Hey now! Don’t make me break out the 'boots! ;D


Hi all, ive had boclean for a few days now & it has been erraticly going into ‘green’ icon lock up as op said (including the hour glass cursor over the boclean pop up menu).
I tryed uninstalling & carfully re installing with all my system add ons shut down, no change, it seems to happen when i run ie (dont know if thats important).

However I have found something that makes boclean behave better (no lock ups yet for many hours, usuly the fault is fearly quick to show up) ive stoped the auto update & am doing it manualy then shutdown & restarted boclean…all good.
Ill post progress in a few days,Ive included my process list (blacked out my name). (:WAV)
xpsp2 celeron 2.4 ghz 3/4gig ram

[attachment deleted by admin]

Sorry to say, though 4.23 was a thorough embarassment, 4.24 has not only proven to be flawless, but has solved all of the remaining problems which dwelt in all previous versions, including 4.22 under PSC. There have been ZERO problems with 4.24 which proved out to be BOClean at all. And though I’m kinda really enjoying typing this upon the facts, know it isn’t halping YOU any.

Behaviour you’re writing about though is very clear … you have a HIPS, or a firewall that is JAMMING the call of BOClean to its “child process” to perform the update. What you NEED to do is inform whatever OTHER security software you have installed, that it’s OK for BOC424.exe as well as BOC4UPD.exe to “call out” … there’s no privacy ramifactions, all they do is contact COMODO’s server, ask it what the timestamp of the update and SIZE of the file happens to be, compare it to the existing one, and if the server has something different, go ahead and grab a copy of it and install it. That’s all we do.

But something ELSE you’re running is not only stopping the update, it’s stopping BOClean from recovering by jamming it in a MOST unusual way. Normally, BOClean will let the update try for “x amount of time” than then just give up. Something you’ve got there is futt-bucking it. Would LIKE to know what it is, so we can declare it a nasty and delete it! Heh.

Kevin, just checked my firewall (CFP of course) and I see BOC424.exe and BOCUPD.exe allowed, but the last one (BOCUPD.exe) is there twice.
Is the duplicate needed or have I just ‘allowed’ it twice by some quirk of fate?

BOClean is great and no problems whatsoever.

Thanks for all your hard work,


Moo! Ain’t got my CFP chops together yet … I’m still on the “old system” here myself … but if you’ve got duplicates, OBVIOUS that it’s permissions for the CURRENT and the older version somewhere still residing. I know there’s folks who revel in archiving older stuff … but betcha yer not one of them. :slight_smile:

No Kevin, no older versions here, just been using both for 2 or 3 weeks now and both the latest versions. No harm in leaving them I suppose, don’t want to upset anything; working so well.