BOClean doesn't automatically start at startup of pc

Hi there, I’ve been using BoClean for a while, no real problems with it at all. it’s wonderful. Ever since I updated to v. 4.24 (thats what it says in task manager) BoClean won’t start up when my computer starts and I have to manually do it.

Before anyone says anything, yes, the option “automatically start boclean at bootup” is checked in BoClean configuration options.

I’ve also stopped my spyware terminator and teatimer (spybot s&d) protections from running at bootup. Now all I have is Nod32 and Comodo Firewall starting with my computer and they shouldn’t be stopping anything. I have nod32 tell me when it does anything and Comodo has always been set to allow it.

Also, BOCore in services menu (services.msc) is set to run automatically and is currently started as it should be since BoClean is running.

Any idea what’s happening?

you could try unticking “automatically start BOClean”, in BOC’s “configuration”, and then re-ticking it… maybe that will add the regkey to your registry’s “startup”…

you could check, in your registry, to see if the BOClean regkey is there, in your registry’s “startup”… that would be in:


you could open “task manager” and check to see if “BOC424.exe” is running… maybe it is running, but the icon is just not showing up in your computer’s “systray” (down by the clock)…

last option, you could try uninstalling BOC, making sure that no remnants of BOC 4.24 or BOC 4.23 are left and then reinstalling BOC… in other words, a “clean” reinstall of BOC…

let me know if BOC424.exe actually is running, only without the BOC icon’s being displayed in the “systray”…

Hi redwolfe, Boc424.exe is not running in task manager, however, BOCORE.exe is running in task manager and must have been since startup. I’m not sure what the difference is between the two, but it sounds like there’s a problem somewhere. I will perform the other steps you recommended and check back here.


BOCORE.exe IS BOC - that’s the back-end of it, if you will. BOC424.exe is the front-end, the user-interface aspect of it.

I would also suggest checking msconfig for a startup entry on BOC424.exe. Sounds like that may be missing.



I have a simillar problem, except BOCore.exe and BOC424.exe are running but the icon does not show in the system tray. I tried uninstalling and re-installing but I don’t get the Front-end icon showing. I have BOClean running on multiple PC’s without any problem at all. But this one PC does not want to show the Icon. I am signed on as the system admin and I’m runninig winxp sp2 with the latest updates. I have CPF 2.4 runninig and AOL AVS running.

Does anyone know how to get this icon showing in the system tray?


Little Mac, Boc424.exe is running in msconfig. Just reinstalled Bo Clean for the heck of it and is running fine now even after 10 restarts.

Have no idea, but that has happened before.

I may not be the one to say (and am not), but sounds like Bo Clean might be having a few problems. I posted another post all too recently about Bo Clean shutting down with an error after detecting trojan. That to has happened before.


That’s not necessarily a cause for concern; as I understand it, in some cases some malware is a little rough on the system and on BOC; it may shut down or shut down the system on removal. Now, I don’t know specifics of when/where/how this might happen. So it’s always possible that something is wrong.

At any rate, I’m glad the whole systray thing is working for you now. Hopefully it will continue to play nicely.

Alfred, if the service (BOCore) and the GUI (BOC424) are running, I do not know why you wouldn’t have an icon in the systray, unless you at some point changed BOC’s configuration so that it would not display (checkbox in the config window "Permanently hide tray icons & alerts). If that was done, afaik, it’s a permanent change used/recommended for corporate situations where there’s an Admin in charge of the network and they don’t want users fiddling with the application.


Thanks Little Mac for the reply. I’m pretty sure that was left unchecked but I will double check when I’m at the office.