BOClean 4.26 Crashing on Vista SP1

Since installing BOClean 4.26 on SP1, it crashes about 5 minutse after the system starts up (and BOClean starts up). I installed 4.26 2 days ago and have had the problem since then. I haven’t had an issue with 4.25, but no longer have the installer for that.

I get the message “BOClean has stopped responding” from the OS …

Welcome to the forum Iria, i updated Boclean when i was informed that there was an update and i have i had no problems since (and yes i’m using Vista with SP1)

How is that going to help him? ;D

Hi Iria,

Sorry you are having this problem. Try uninstalling Boclean, Reboot, then install 4.26 again and see how things go.


Strange one indeed … FWIW, that “5 minutes” is about the time that BOClean would try to do an automatic update and whilst it calls an external program called BOC4UPD.EXE to do so under all other operating systems, under Vista it’s done internally owing to the annoyance that is UAC requiring an admin password to do its thing. That’s about the only correlation I see here, and it would indicate some sort of “block” on the autoupdate which is holding BOClean hostage somehow.

What you might try is a “manual update” and see if that hangs. It could also be another security program or the Windows firewall blocking the connection since BOClean should be set to have the necessary privileges already without bringing up UAC when it goes to update. But that sounds like what the problem might be and needless to say, despite extreme testing under Vista and SP1, never had that happen. So something’s unusual there. But that’s my best guess since once again, can’t make it happen on any of our own lab rats …

Just so you know, I’ve been using BOClean since long before the Comodo acquisition. I’ve also been in PCs for 20 years so you can bet most of what you would suggest, I’ve already tried.

I also have BOClean 4.26 running on another PC just fine, but it’s XP.

Anyway, I already:

  1. uninstall / reinstall (incl. reboot)
  2. manual update … that goes OK.
  3. running it after the crash manually. Goes 5 minutes then crashes again.

Suggestions? As I said 4.25 was running flawlessly for me. If I could get a download link I would like to reinstall it.

I have to say that BOClean has saved me a few times in the past when NOD32 missed something … perhaps I have become cocky with it … so I’d love to have it back on my system.

MMMMM…i guess you’re right my comments ain’t gonna help much…better make way for the experts…that’s your cue by the way!

I’ll watch what i say in the future!

Weird with a beard indeed … so far, this is the only one. However, I also believe in “mine canary syndrome.” If something weird happens once, we’ll see it again and thus it matters. So let’s try a little experiment so we can try to zero in on what’s going on there. That 5 minutes thing has me on that same theory that something’s seriously clanging the autoupdate trigger, and unfortunately the code itself is clean.

Right click on the traybar icon when you go to start it, select “configure BOClean” and when the configuration screen comes up, look for a checkbox up on top marked “Check for update every [ ] hours …” and UNcheck it for now. Then hit finished, close the menu for BOClean and let’s see what happens. We can turn this back on again once we see if this makes any difference, and we’ll take it from there.

We’ll figure it out yet! :slight_smile:

OK, I am reinstalling and I will try that. One thing I noticed: I had uninstalled 4.26 and I also went into clean out any (typically) left behind directories and I saw that the BOCLean 4.25 exe was still there, despite me running uninstall as instructed before installing 4.26.

Just a data point.

I manually deleted the folder and reinstalled right now. I will reboot and see what happens.

Well, I reinstalled at the time I wrote above. And because I had found that .exe remaining, I decided to let it run with default settings. And it ran all day until just now. Crashed the same way. I copied the crash details below. Note this is with auto update on and it seems it updated at 4/18 14:30:51. So maybe it WAS trying to get an update, I don’t know. I am disabling auto update now.

Problem signature:
Problem Event Name: APPCRASH
Application Name: BOC426.EXE
Application Version:
Application Timestamp: 00000000
Fault Module Name: StackHash_e52f
Fault Module Version:
Fault Module Timestamp: 00000000
Exception Code: c0000005
Exception Offset: 20202020
OS Version: 6.0.6001.
Locale ID: 1033
Additional Information 1: e52f
Additional Information 2: e98dfca8bcf81bc1740adb135579ad53
Additional Information 3: 860f
Additional Information 4: 6eabdd9e0dc94904be3b39a1c0583635

Read our privacy statement:

Wow, I restarted and turned off auto update and it crashed again already:

Problem signature:
Problem Event Name: APPCRASH
Application Name: BOC426.EXE
Application Version:
Application Timestamp: 00000000
Fault Module Name: StackHash_e52f
Fault Module Version:
Fault Module Timestamp: 00000000
Exception Code: c0000005
Exception Offset: 20202020
OS Version: 6.0.6001.
Locale ID: 1033
Additional Information 1: e52f
Additional Information 2: e98dfca8bcf81bc1740adb135579ad53
Additional Information 3: 860f
Additional Information 4: 6eabdd9e0dc94904be3b39a1c0583635

Read our privacy statement:

Read both, going with this one for the reply then. :P0l

Congrats, you’re the official mascot of “sunspots and acne” for now since you’ve got a rather interesting and elusive one there! Heh. OK … my first stab at “WTF” was the “5 minutes” thing. That, as I’d indicated, would point at something on the “countdown to startup try for an update” thing and would have been something “possible.” Since it worked “all day” once, and then did something even stranger on the next run, I think we can safely eliminate the “4.00 minutes after startup default ‘check for update’” as being any part of the problem, and along with that the “trick” I’d mentioned earlier will be “no joy” either.

For YOUR benefit though, I want to take this to IM while we work on this privately, since I’m going to need to ask you a big favor here … I need some diagnostics data out of your copy of BOClean to analyse and it will contain some of your own personal, private information. So I want to allow you to bring the information I need into notepad and edit out anything you’re uncomfortable about and then send the rest to me to have a look at. This is the reason I want to do the next step in IM as a matter of respecting YOUR privacy and not allowing others to have a look at it by posting it publicly here.

Need you to use the “search” feature (be SURE to adjust the settings so that it looks EVERYWHERE on your primary hard disk) and look for a file called BOC426.INI … there will be one for certain in your \WINDOWS folder which is the “master copy” … however, there might beother copies of BOC426.INI located in obscure folders as “personal store” stuff … Vista is a pain in the ■■■■ about making copies of copies of copies and then using the wrong one. :frowning:

Look for whichever BOC426.INI is the largest file size, look it over in notepad, and then copy and paste the results into an IM for me to look over. No one else will … hopefully from what’s listed in that, we can go the next step. If necessary, might also point you to another tool you’ll need to do if this doesn’t point me at some suspicious externals to check out, and we’ll go to the next level if I can’t guess from the INI file what might be going on. I now suspect the problem is either an errant driver, or something else interfering. Hopefully, there will be an “aha moment” within the contents of the INI file.

Now switching to the “professor hat” … I imagine folks might want to know more about these “crash dummy” boxes and what they mean, particularly here. I’m in a good mood since I’ll be going to bed soon, so let’s have some fun learning about windows and crashes … might be useful. :slight_smile:

The “c00000005” errors which appear in many programs that make windows “pass gas” are the result of a program calling a section of memory which is “not defined.” In other words, calling a black hole, being “shot into space.” This can occur when a program calls a section of memory which just isn’t there anymore, or went home based upon it being “unlinked.” Bottom line is that the program is literally walking off a cliff because something went away.

The “crash” is an “unhandled exception.” When program calls a function, or an address in memory, Windows looks in active memory for what you want. If it doesn’t find it, then it goes to the “swap space” on disk to look for it, figuring that it put if there. If it doesn’t find it there then it stops trying and “raises an exception” along with an error back to the software that asked for something Windows couldn’t find. Microsoft’s vision of how people should code is reflected in three kernel functions for “exception handling” called “__try, __except and __finally” wrappers around each and every function call. “Try” portion is the normal code. “Except” is “what do you want the program to do if it fails?” and “finally” is … do this to HIDE the error. Well, I don’t code that way. If something goes sideways, I’d like to know about it, and that’s why you’re here. :slight_smile:

So FWIW, “crashes” are a major biggie as far as BOClean goes and if something goes wrong, to my mind at least, I want alarms sounded so loudly if that happens that folks will bring it up. Sweeping bugs under the carpet was never my style (though in the end, those that didn’t bring out a new version immediately were never ours in the first place, but we dound the culprit at least) and COMODO has even less tolerance for buggy software than even I ever did!

Something’s playing peekaboo there, and if you google the words “Vista SP1 crash” you’ll see that there is a cast of thousands of culprits out there … apparently SP1 “qwapping the bed” is rather commonplace unfortunately. All I can offer is that if there’s anything in BOCLEAN itself going sideways, I wrote it … I can FIX it! :slight_smile:

If it’s something else though, we gotta find it and let them know, and then find a way around it for YOU that will at least get us out of the “sunspots and acne” phase … heh. So give a look for the longest of those files, send it to me in an IM and let’s see what we can do … as I’ve said before, you’re the only one so far - I’m SURE you won’t be the last to be there, wanna do everything I can do. I have this personal thing about stab wounds down the road. :slight_smile:

just want to throw in that this issue looks pretty familiar to me.
meaning i’m the second one where boclean crashes.
i’m running vista business x64 (german). clean install from scratch a few days ago
on a new machine w/ a core2quad (q6600).
after some time, boclean goes down with the same messages described
by Iria.

hope that it can be fixed soon.

OK, just FYI my home PC is the only one that exhibits this (since my work PC is XP, ya know) so it’ll have to wait until I get home.


someone I know of has the same problem as Iria. Especially BOClean crashed right after switching off autoupdate. That’s on german Vista Home Premium SP1 Laptop Samsung Aurora R70 2 GB RAM. I will send those file(s) by PM in some minutes. (done)

On WinXP SP2 I myself have no problems. It’s this ■■■■ Vista thing that sucks big time, you know what I mean. 88)

So far, everyone has only a few things in common, but all the cases so far share, so maybe this will help. Everyone is using Vista SP1 “German,” everyone is running NOD32 and so far, everyone has Widcomm bluetooth installed. There are “known issues” with Vista and earlier USB/bluetooth drivers so that’s a possibility. Considering also that every new version of BOClean has run afoul of NOD32, for the moment that’s my main suspect though I don’t understand how it would only affect Vista SP1 and only in Germany. But that’s all I’ve got so far …

So give this a shot and see if it helps for now …

— thanks again to JRB for the instructions which follow:

Start the NOD32 Control Center.
Click on AMON.
In AMON click on Setup.
In AMON setup click on Exclusions.

You can now add files and folders to exclude in AMON.

Exclude the BOClean files and folders, and each of them both in long path format and in short path format.

Here is the list that I myself have excluded:


If you like, you might also want to try to do it the other way around:
Exclude the important NOD32 files in BOClean.

I need to see about getting a diagnostics program I used to hand out hooked back up for download - the FTP site at is no longer, and that’s where I kept it. Will see about getting it together as quickly as possible.

Wait, I’m not using German …

Just crashed even with it excluded from NOD32

Sorry, got two responses yesterday, thought the second one was yours. Currently I’m in the midst of serious email outage on my end and so will get back to you once it’s been fixed with an email address to send it to. I’d also recommend to everyone else to keep an eye on this page so we can get to the bottom of what’s broken there. Something is pulling the rug out, and I still think it’s Vista choking on someone else’s driver since ours has NOT changed since 4.25 nor have any of the involved bits of code. Were it not for this, I’d already have an idea of what’s hosed and have been going back and forth over the code I wrote with absolutely no correlation so far that would point me at the culprit.

Once I have email again, will let you guys know … sorry for the German thing, but what I mentioned earlier was from two different people and those were the correlations. Promise I’ll get back once I have communication again!

The thing is, if nothing’s changed since 4.25 - well, 4.25 was just fine on that same PC.


I’ve collected the data, and am still awaiting instructions on how to get it to you as it can’t be pasted into a PM. I suppose I could send several ■■■ with the data, but an attachment would be easier.