Bocked Application List doesn't delete items

I just updated to Firewall The items on the Blocked Application list do not get deleted when they should. Windows 7 Pro 32bit

I clicked purge and one item was removed - still on list even after refresh or restarting PC
I checked all the items and clicked “remove” - same result as above.
I checked items one at a time and unblocked them - list updated for a moment but then item(s) reappeared - no difference between unblock for one component or all.

The remove function worked great when it was first introduced.

Note: I did a system restore which put the CIS Firewall back to v10.0.2.6420. The About Help says it is still version but checking the .EXEs the older version was restored. The purge, remove and unblock functions work as they should and the Blocked Applications list removes the updated items.

Bug that is fixed with the new CIS version coming out today. See here for the bug topic.

I still have the same problem with CIS on two different laptops.
I have version 10.1.0 6476.
When I press PURGE CIS tells me that it is going to delete the items from the list as they are not valid, but it doesnt remove them??

Can you tell me how to fix this?

Follow the directions in this post to update to the latest version or wait until updates are released for all users early next week.