BOC425.exe and CFPv3 Defense+

Hi, I have a problem.
Installed CPFv3 a couple of days ago and that worked fine with BOClean with no problems.

Switched on Defense+ this morning (in Clean PC mode) and it started to learn OK.

However the next time I rebooted after a short time it started to throw up Defense+ alert boxes (BOC425.exe), every few seconds. Allowing the aplication did not cure the problem and I had to switch off Defense+. Is this a known problem. Ideally I would like to keep Defense+ enabled and keep BOClean of course.


Thanks,

Mike.

Hi Mike,

Defining BOClean as “trusted app” works for me. Answer the popup with treating as trusted app and remembering.

Unfortunately that didn’t work for me. I tried every variation but no joy, just another pop-up box every few seconds. :frowning:

Thanks for your input; it may work for someone else. :slight_smile:

What I cannot understand is how Defense+ cannot recognise a program from it’s own company as safe. ???

Mike.

Yep it seems that BOClean isn’t even digitally signed by Comodo. ???

There might be a problem with CFP’s memorizing answers, I figured it might not work. Then try going manually to Defense+ > Advanced > Computer Security Policy, find the instance for …\BOC425.EXE. Does it show “Trusted Application” or “Custom policy”? If it’s not trusted despite your answers to the popups, double-click on the instance, select “Use a Predefined Policy”, and select “Trusted Application”. Click on Apply, Apply…

Let me know if this works because I was starting to think that there’s a problem with CFP’s remembering rules after popups and this may confirm it. Also are you running Windows as admin or limited user?

Thanks Japo, I will try and find time tomorrow to check this out.

Is this happening to everyone who is trying to use BOClean and Defense+?

Can BOClean be digitally signed; this would surely correct the problem?

I’m running Windows XP home as a single user.

Mike.

Yes I think that everybody is having popups about BOClean unless they grant appropriate permissions. What I don’t know for sure is whether all of them are forced to access the Computer Security Policy, or if answering the popups with remember enabled is enough. But I was having some problems about popups appearing more times than I thought they should, not only with BOClean.

Let’s hope future versions of BOC come signed, besides that’s within Melih’s and Comodo’s doctrine.

Hi Japo, the fix didn’t work with Defense+ in Safe Mode.

Followed your instructions to the letter.

Rebooted and found I have to set BOClean for each application as ‘Trusted’ which thankfully allowed the applications to open; then it happened again, a deluge of BOC425.exe alerts which wouldn’t go away, so many for the same application or file that BOClean was opening. Setting them all for ‘trusted’ did no good either. :frowning:

Such a pity the fix didn’t work, all other functions of Defense+ seemed to work.
Have had to disable it again; can’t live with all those Alert boxes that never stop. :frowning:

Please let us know the permanent fix for this when it is sorted.

Thanks,

Mike.

Mike,
Sorry for the delay, I’m on the “midnight express” this week. 88)
I’m guessing/hoping this is a configuration issue with CPF 3 as I’ve seen no problems on mine but I don’t know for sure.
BOClean was already installed here when CPF 3 joined our family. CPF 3 was allowed a default install other than identifying 2 trusted networks…
I’ve flagged this for review so we can get you some answers. :wink:

Thanks Cat,
I had to disable Defense+ as I said before.
However I did get just one BOC425.exe alert (without Defense+ running) this morning on CPFv3. I can live with that; although it had already been granted permission.
Do you think getting BOClean digitally signed will cure the problem?
Mike.

Hello,

I’m new to the forum, so I regret my first post is about a minor annoyance with an otherwise great product…

I have the same problem Mike G describes. Even after the procedure Japo recommended, I still get dozens of popups for BOC…

One hint that might help: I have 2 instances of BOC25 in the list of trusted apps. Same goes for the firewalls own cmdagent.exe.

1 instance under c:\progra~1… and 1 under c:\programme.… (my Win XP is Grman)

Removing one each doesn’t solve the problem either.

Here is a screenshot to show that these alerts pop up even when I used the process described by Japo

Hi PanzerG, welcome to the forum.

I think that the main reason that we are having this problem is that BOC425.exe is not digitally signed (trusted) by Comodo; which I find very strange.

I guess as BOClean is a security product, in a way, it’s having some kind of conflict with Defense+.

No doubt in time the powers that be will sort out this problem for us; after all CFP v3 is very new and there are bound to be a few bugs that need sorting; all new programs have bugs, and it’s impossible for a programmer to envisage every possible configuration of a PC.

In the meantime we will have to disable Defense+; we did do without it before it came along, but I do think that it is a good extra level of protection. :slight_smile:

MikeG

Mike,
I haven’t heard anything back yet, I imagine things are a little busy in the dungeon about now.
I’ve IM’ed the people that should be able to shed some light on this, hopefully they’ll find there way over here before too much longer.

Thanks Cat, will keep a lookout on this thread. :slight_smile:

Hi,

It seems like this is related to a bug in 8.3 file name format. We have fixed the issue. We will issue an upate(hopefully this week) which will fix many bugs inckuding this one.

Thx,
egemen

Thanks, will look forward to it.

Mike.

egemen, you rock buddy! :wink:
Keep up the good work, we really appreciate it.

If you’ve ever tried getting basic support from Symantec or McAfee you’d understand how cool this is.
:wink:

Just curious, would disabling 8.3 file naming under Windows help, if, as egemen said, it’s related?

I’m still playing with V3 ‘Raw’ so to speak, so I haven’t reinstalled BOC yet.

Here’s a how to if anyone affected wants to try.

How to Disable the 8.3 Name Creation on NTFS Partitions

My installation must be charmed… Defense+ is set to train in safe mode and I haven’t had a problem. :-\

I have had this problem a couple of times since installing CFP - 3. I have always solved it by removing all the 8/3 filenames (the ones with the ~) and entering the app in full path and then make it either a trusted application, a browser or whatever it happens to be. After clicking apply, it then had to be followed by a re-boot. It has not been a big problem and has only happened a couple of times, so I have not even reported it before. Glad to see that it will be fixed though.

John

Defense+ in CFP is on Clean PC Mode and in Firewall it is on train with safe mode.