Blu-ray movies unable to play with PowerDVD [M1542]

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
Every time
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1:Install Comodo Firewall
2: Play a Blu-ray through Cyberlink PowerDVD 14
One or two sentences explaining what actually happened:
Error message “Cyberlink PowerDVD cannot access the storage device. Select another device when playback stops.”
I close this error box and another error is reported:
“Cyberlink PowerDVD could not launch because some of the components appear to be corrupted…”
One or two sentences explaining what you expected to happen:
Cyberlink PowerDVD should play the disc.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Yes. I entered appropriate exclusions under “Detect shellcode injections” but it did not help.
Any software except CIS/OS involved? If so - name, & exact version:
Cyberlink PowerDVD 14.0.4704.58
Any other information, eg your guess at the cause, how you tried to fix it etc:
Uninstalling Comodo fixes the problem.

Exact CIS version & configuration:
Comodo Firewall, default configuration.
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Default settings (Firewall safe mode, Viruscope enabled, auto-sandox not enabled)
Have you made any other changes to the default config? (egs here.):
Have you updated (without uninstall) from CIS 5, 6 or 7?:
if so, have you tried a a a clean reinstall - if not please do?:
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Win 7 Professional 64bit
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a= 360 Total Security

[attachment deleted by admin]

I think this should still stand as a bug which needs fixing, but I found the issue can be resolved by following instructions given here by MSB

Go to Advanced Settings/Security Settings/Defense+/HIPS/HIPS Settings. Under "Detect shellcode injections" click on Exclusions and click on the little upwards ^ sign at the bottom. Click on Add and find the PowerDVD.exe and PowerDVDMovie.exe files.

I had already tried this with PowerDVD.exe but PowerDVDMovie.exe must also be added. This was found in Program Files (x86)/Cyberlink/PowerDVD14/Movie/
For good measure I also added PowerDVD.exe.manifest and I don’t know if that was necessary.

I still can’t play a blu ray, but the issue is no longer with Comodo!

Please provide a direct link to ‘Cyberlink PowerDVD 14’.

Thank you.

360 Total Security and Comodo Firewall could be conflicting causing unexpected results or issues.

I have not found any conflict issues between Comodo and 360 Total Security. As posted above, the issue was purely with Comodo blocking some of PowerDVD’s executable files. The remaining issue is not related to either Comodo or 360 Total Security.

Although I only purchased PowerDVD 14 nine days ago, I see it is already superseded by PowerDVD 15.
I have found Cyberlink’s online support poor.

Do you experience this issue with ‘PowerDVD 15’ ?
Also, I can’t seem to find a mirror to the exact version listed in your report.

Okay, here’s my 2 cents…
The latest update to CIS broke ALL Blu-ray access for me (running W7 x64 with all latest updates). I have tested it with CyberLink PowerDVD v12, v14 and v15. Broken. Tested it with AnyDVD and VLC. Broken. Tested it with Windows Media Player (with media package installed). Broken.

I removed CIS from the PC (the only change) and ALL Blu-ray access was restored. Every program that could previously play Blu-ray discs once again worked. I reinstalled CIS and ALL Blu-ray access was again broken.

The funny thing is that I have HIPS turned OFF in Firewall config, but adding exceptions for the various media player executables fixed the problem. Obviously there is a bug in the latest version of CIS.

I know CIS firewall is free (thanks for that!), but it would be nice to see this bug squashed.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time, availability, and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Thanks again

I couldn’t reproduce this bug with version with VLC media player and windows media player.

@pennymachines, could you confirm?

Thank you.

I’m sorry, I can offer no useful input because I returned the PowerDVD software for a refund.
On top of the issue I reported, there was another issue, unrelated to Comodo, which prevented it from working.
After wasting many hours with several different software solutions attempting to get more than a handful of blu rays to play consistently on my desktop, I gave up.
Thanks for your efforts.

Should be fixed with CIS so moving to resolved. If you feel that this is not fixed please PM a moderator. Thanks.