Blu-ray and DVD movies unable to play (UK)

A. THE BUG/ISSUE (Varies from issue to issue)

Summary
Unable to watch blu-ray or DVD films in powerDVD, WinDVD or Arcsoft.
Can U reproduce the problem & if so how reliably?:
100% repeat on four PC’s

If U can, exact steps to reproduce. If not, exactly what U did & what happened:
1: Install Comodo ISP 8.2.0.4508
2: Play a Blu-ray through any software

If not obvious, what U expected to happen:
Play my films god dam it

If a software compatibility problem have U tried the conflict FAQ?:
No, but just uninstall Comodo fixes the problem

Any software except CIS/OS involved? If so - name, & exact version:
No

Any other information, eg your guess at the cause, how U tried to fix it etc:
No fix, but I can’t change my region code which wasn’t locked before

B. YOUR SETUP

Exact CIS version & configuration:
8.2.0.4508

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
default from Comodo ISP

Have U made any other changes to the default config? (egs here.):
No

Have U updated (without uninstall) from CIS 5 or CIS6?:
No

if so, have U tried a a clean reinstall - if not please do?:
No Just tested this and its not fixed the problem

Have U imported a config from a previous version of CIS:
No

if so, have U tried a standard config - if not please do:
No

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Win 7 64bit home P

As far as PowerDVD goes go to Advanced Settings/Security Settings/Defense+/HIPS/HIPS Settings. Under “Detect shellcode injections” click on Exclusions and click on the little upwards ^ sign at the bottom. Click on Add and find the PowerDVD.exe and PowerDVDMovie.exe files.

This will probably also work for the WinDVD and Arcsoft executables as well.

Thank you MSB.

The HIPS was disabled?

I enabled HIPS.
Then added all exe on PowerDVD root and movie folder
Started PowerDVD and checked region settings and everything is correct

So I’m guessing this is not a bug?

It isn’t a bug as far as I know but with all of CIS’s sophistication I can’t see why this can’t have been done automatically - the executables are trusted.

Please attach a video reproducing the issue.

Thanks.

I’m on Win 7 professional 64bit with Comodo Firewall 8.2.0.4591 and have a similar problem with Cyberlink PowerDVD 14.
Cyberlink suggested the steps above, but to no avail.
Screengrabs of the 2 errors are attached. The first error is immediately followed by error 101.

[attachment deleted by admin]

This isn’t the same problem. Looks like your installation is corrupt. I suggest you do what the last dialog asks.

I already tried that several times but the errors persist. Cyberlink identified this as a Comodo issue and suggested the same steps re. HIPS exclusions detailed above.
Indeed, I know it is an issue with Comodo, because by uninstalling the firewall the problem goes away.

I suspect that you’re experiencing a different issue. Please create another bug report with the required format.

Thank you.

I have posted a bug report here and a workable fix I found from forum member MSB.

Yes, the latest version of CIS breaks Blu-ray playback regardless of the player software used:
https://forums.comodo.com/bug-reports-cis/bluray-movies-unable-to-play-with-powerdvd-t111744.0.html

HIPS is not enabled on my machine, but adding a HIPS exclusion for the player executables fixes the issue. The exclusion should not be necessary with HIPS disabled, but that’s what allowed me to view Blu-ray movies with CIS installed.

Already reported here:
https://forums.comodo.com/format-verified-issue-reports-cis/bluray-movies-unable-to-play-with-powerdvd-m1542-t111744.0.html