Blocks ALL trafic: help! [Resolved]

Yesterday I downloaded the Firewall Pro 2.4.18.184. I am running XP sp2.

I was so amazed by the painless installation and the WOW I got from the vivid GUI, that I could not believe my luck.

After automatic set-up (turned off Windows firewall etc), the message “all is up and running…” appeared in the system tray, the protection indicator smiled green.

I connected in a usual way via GPRS using BeauSoleil 1.6.1.4, the connection icon showed up fine in the tray.

Then the Firewall fired up a couple of prompt-alerts where I allowed each and every request. The alerts were gone and I went to my browser, first Opera, then, IE, but there seems to be ABSOLUTELY NOTHING happening. Zero traffic both directions on all ports!!! No additional alerts, but not only browsers, but also FTP and POP+SMTP were dead. And the Firewall kept showing green and smiling happily.

I then tried it on a dial-up connection - the same effect. Connects, ok. But then again absolutely NO traffic throughput whatsoever! (All rules say Allowed and UDP loopback is automatic).

Then I googled and yahooed tons of sites, these forums included, but never saw a description of my problem.

However, I manipulated the settings - turned off behaviour analysis, then unticked do protocol analysis or something (as they advised somewhere) - rebooted a dozen of times after changing settings - the same deadly lock on my connections.

Nothing seems to work.

I completely uninstalled a good McAfee Firewall before I decided to try Comodo Firewall Pro, and it would be VERY SAD, if I couldn’t give this amazing product a good run.

Please help me not to revert to McAfee!!!

Hi jaarik, welcome to the forums.

Sorry you’re having problems. Check CFPs Log (Activity tab - Logs). If CFP is blocking something then it usually logs it. The log can be exported to an HTML file & then you can simply cut ‘n’ paste entries to here, but remember to mask any private IP numbers.

BTW What is BeauSoleil 1.6.1.4? I’m not familiar with that.

Edit You can also set CFP to Allow All (from the systray icon) to test if indeed CFP is the root cause. If it works with the Security Level set to Allow All & not Custom, then it probably is CFP.

IIRC, BeauSoleil (wasn’t it BlueSoleil?) uses your GPRS cellphone as a modem via BlueTooth.

Thanks pepoluan. :slight_smile:

thanks indeed for your involvement, kail! i hope you and the rest of the guys can solve my problem, because i am beginning to get desperate.

i did as you asked and here is the result of my futile attempts…

  1. i uninstalled and then again i did a fresh install of comodo
  2. immediately after reboot it showered alerts on me - i made sure i allow everything, svhost.exe and the whole bunch of them. plus, i set the protection level to ‘Allow All’, the icon in the tray turned green, inside firewall gui it read ‘Bad’ (on protection monitor)
  3. i connected via GPRS on BlueSoleil - ZERO TRAFFIC!!! (all it showed was the negotiation bytes - 324 i think.) browsers would not browser, neither would the mail download. (cannot find/connect to server, blah blah blah)
  4. LOGS are completely clean - nothing was blocked at all, at least according to comodo!
  5. disconnected, turned off application behavior analysis, unticked ‘do protocol analysis’
  6. rebooted again
  7. connected via GPRS, everything stayed the same: zero traffic both ways, nothing it the logs, all up and running according to comodo, but i was again in somber mood.

What is going on?

Please help, I am on the verge of disillusion!

Eagerly awaiting your replies!

My bet: McAfee is still there, regardless of your attempts to uninstall it (I’ve experienced this too many times to count), and has interfered with the installation/function/reporting of CFP.

LM

I don’t know what’s going on unless you have another security app installed (do you?). With CFP set to Allow All (yes, I know CFP would say “bad”) then nothing should have been blocked and this was reflected in the Log (you would expect the nothing reported in the Log with CFP set to Allow All). With CFP set to Allow All turning ABA & Protocol Analysis off shouldn’t have had any impact. Is anything reported in the Log when CFP is set to Custom when you try to connect?

Without ABA (Application Behavior Analysis) you don’t have any active leak testing. Not a good thing.

With regards to BlueSoleil you could try setting that application to “Skip advanced security checks” (Application Monitor - Edit app - Miscellaneous tab) & see if that works.

Also for your system to work does it require both ABA & Protocol Analysis turned off?

thanks for your replies!

that’s one maze of a conundrum to me… hm.

setting cfp to custom → same old story, still no throughput.

McAfee?.. maybe, but then, why when i uninstall cfp and reboot, the same GPRS connection works perfectly again, all is back to normal?..

i am getting weary.

guys, can you come up with any more ideas? i seem to be the only one having this problem. is there a cure?

the forum and your support, guys is amazing, and i’d really love this thing to work!

Hi jaarik. If Allow All doesn’t work it’s definitely not a problem with your rules. There are some related topics, where I suggested a winsock repair. Hopefully these will present some ideas:
https://forums.comodo.com/index.php/topic,7650.0.html
https://forums.comodo.com/index.php/topic,7231.0.html

I’ve seen it happen, when a previous firewall wasn’t quite gone. It ended up being blocked with no evidence, in CFP. Allow All wouldn’t work. Uninstall of CFP, then it works fine, with “no” firewall. A registry search revealed junk left over. Doesn’t mean that’s for sure what it is, but I’ve got some money ridin’ on it… :wink:

Here’s the first level test to perform. Search your c:\ drive for McAfee files or folders (or any related…). They’ll be there. Try to delete them. I pretty much guarantee you won’t be able to; they’ll be “in use.”

Then go to Start/Run, type “msconfig” and go to the Startup tab. Make sure there aren’t any active McAfee entries; if there are, uncheck them, Apply, Close, and reboot.

Then go to Start/Run, type “regedit”. Search for any McAfee entries, and delete them. If you feel more comfortable, you may use a program like RegSeeker to search for you; it will automatically make a backup before removing. Then reboot again.

Go back to the McAfee files and folders, and try to delete. Now you should be able to.

You’ll probably need to uninstall CFP, reboot and reinstall. Prior to running the install package again, be sure to disable/turn off any active/real-time/on-access security - AV, AS, HIPS, etc. These may conflict as well.

LM

I shall conclude this topic with jubilation. Thums up for Little Mac! Thank you very much indeed! You were right after all.

Let this be a definitive symptom->solution guide to anybody with the same problem…

So, after all, I did what Little Mac suggested, and to my consternation I found TONS of hidden services, dlls, hidden undeletable legacy drivers of McAfee and Panda antivirus I used to have in the past. I myself packaged my own programs for distribution, but those two “reputable” software manufacturers miserably failed to deliver a clean uninstall solution. I would not consider either of them in the future. They seem to help when you use their products, but take revenge for ininstalling them! Despicable.

What I did was:

  1. FORMAT, clean XP sp2 install
  2. installed Comodo Firewall Pro

AND - I could not believe it after an eternity of hope - it worked EXELLENTLY from the first time with automatic configuration.

Praise the Lord!

Thanks again to all good people who have contributed to this topic.

So how much did you wager and won this time? (:CLP)

I’ll sing the Hallelujah chorus with you, jaarik (but in the privacy of my shower, for everyone’s benefit). I’m glad you got it all straightened out, and have such joy now…

We’ll go ahead and mark the topic as Resolved, and close it. Should you find for some reason you need it reopened, just PM a Moderator (please include a link) and we’ll be glad to do so.

LM

PS: Soya, You know I can’t divulge my “winnings” on this forum… ;D