Blocking ports for Apps [Resolved]

Hi,

I want to block port 6666 only for one application x. How can I archive this?

I created rules for tcp/udp in and tcp/udp out for application x. This are
the normal ports and ips and work great.

Then I created a 3.rule “block tcp/udp out port 6666”. But this rule is ignored.
Is there a possibility like in “network monitor” to prioritze this rule?

Thx
Achim

Hi there,
rules in the Network Monitor are ordered hierarchically, i.e. COMODO parses the rules from TOP to BOTTOM starting with rule 0.
Thus, any specific rule should be placed about the more general, or it will be ignored.
Be sure to move your specific block-rule ABOVE the general allow-rule!
This should do the trick.
Hope that helps.
Cheers,
grampa.

EDIT:
Sorry, it’s always better to think (or read thoroughly) before acting (giving you an answer to a question you never asked).
I’m really sorry - didn’t read correctly.
Just give me a sec to think about your problem - am a bit confused now.

EDIT2:
O.K. just thought about and have hopefully found a way to do it:

You’ll have to delete your 3 rules (you’ll only need 1 - personally I’d add 2 - 1 In, 1 Out - but I think it’s not necessary in this case).

  • add new rule, search for the app (best to learn the parent as there might be a few)
    GENERAL:
  • ACTION: allow
  • PROTOCOL: TCP / UDP
  • DIRECTION: IN / OUT
    DESTINATION IP:
  • select “any” or define an IP-range (as suits best your preferences)
    DESTINATION PORT:
  • define “a single port” (6666) AND!!!
  • tick “EXCULDE (i.e. not the choice below)”
    MICELLANEOUS:
  • up to you

Have never tried it, but it should work.
GOOD LUCK!
grampa.

G’day,

An alternative way to do this is to create an ALLOW rule for the application in the Application Monitor section but on the DESTINATION PORT tab, select EXCLUDE and enter the port you want blocked for that application. This will allow the application to communicate outbound over any port EXCEPT the one nominated.

Hope this helps,
Ewen :slight_smile:

Thanks a lot.

The exclude feature was the right solution.

Good to hear that.
Keeo blockin’, errm rockin’
Cheers,
grampa. (R)