Blocking by hostname: does not work in all cases

Mode 1 (works):

Go to → Firewall / Advanced / Network Security Police / My Network Zones

Create a new zone. Example: ‘Blocked’

Add a New Address / Option “A hostname”. Add for example:

Go to Global Rules and create a new rule blocking this new zone “Blocked” in Destination Address.

Works perfectly!

Mode 2 (don’t works!):

Go directly to Global Rules e create a new rule blocking Destination Address / Host Name. Example: “”.

Theoretically it is the same thing. But … does not work.

I’ve just tried it, Mode 2 works for me :wink:

It does not work. Do not know if you followed or understood the instructions correctly .

Problem is probably that a DNS lookup of gives multiple answers though CIS will probably block only one of them…

CIS does a DNS lookup at system startup, “saves” that answer and uses it on the Firewall policy.

Google is only one example. I tested many sites.

I tried with other sites and does not work (Mode 2).

But if create a Network Zone (using hostnames) works even for Google.

Both ways should work!!

No I don’t think so, the application your using probably has “higher permissions” and allows the traffic before “global” please have a look at the help file and look for the order of rule matching.

From PC to Internet the application rules comes first, next global rules.
From Internet to PC the global rules come first, next application rules.

This is probably why 2 isn’t “working”.

If what you say makes sense, then even creating a network zone should not work … but it works.

“Therefore, outgoing traffic has to ‘pass’ both the application rule then any global rules before it is allowed out of your system. Similarly, incoming traffic has to ‘pass’ any global rules first then application specific rules that may apply to the packet.”

Although the order change, in both cases you need to pass through the two sets of rules.

[size=10pt]PS: Ideally every bug report should be verified by a developer of Comodo, but have a forum where users are heard is a Comodo plan not a reality. Melih???!??[/size]

well, first I have a problem understanding, sorry I’m working on it, second I tested it again now and it works, I blocked the host name directly using method 87 as I can’t understand numbers ??? ??? ??? still working on the problem of understanding, so please forgive me, but I couldn’t understand that it worked for the third time too oh sorry it is the second, can you help me understand it please.
I think a forum is a great way to report bugs, as most of them are not bugs,it is just misusing and can be solved buy ordinary people