blocked-how to allow

Hello everybody. I need little help. I am using program called object dock +, and I once acidentaly blocked that aplication from opening moziila firefox. When I turn off Defence plus Mozzila can run from there. Is any solution how to fix this? thanks.

Hello and welcome to the Forum.

I think you have block and remember this action.

Go to: D+ → advanced → Computer security policies.
Search for the exe of your programm, and then double click.
Click access rights → program execution → blocked tab → delete the entry related to Firefox.

@ adioz86

I need to unblock an .exe file too please… but I can’t find “program execution” under “access rights” ? Don’t know what am I doing wrong, I’ve attached a screenshot.

many thanks.

[attachment deleted by admin]

Run an executable under access rights refers to running Program executable. However, this part refers to opening of an exe file by another program say if java.exe is opened by firefox it will be shown in this category (under access rights of Firefox).

However, if you are referring to parent executable say Firefox in this case, the rule will be available under CIS-Defense±Advanced-Computer Security Policy.

It may also be noted that defense+ at present only monitors exe files. So, you will not see any rule for dlls, xpis etc. under defense+ rules, which means you will not see any entry of firefox add ons under security policy for Firefox.

Hope this helps.

I also have an exe file that is not being allowed to run since I mistakenly blocked it. My problem is that when I went to the “computer security policies”, I deleted the entry instead of double-clicking it. How should I proceed now? Thanks in advance!

If you have deleted the corresponding entry in defense±security policy, you can just run the program and if it is not there in the safe list, CIS will alert you with a pop up and depending on its trust worthiness, you can give the option ‘trusted application’ or just click allow with remember my action.

I would however suggest keeping CIS in 'training mode. Right Clcik CIS icon-defense±training mode, then run the ‘said’ application and then would revert defense+ back to safe mode. This will give the application all the required privilages defense+ will automatically create rules for the program.

However, reverting back, without fail is necessary, as defense+ will give permissions to all applications run in this mode the required permission automatically, with permanent effect.

Thanks Layman. I did try to run the program again after deleting the entry, but instead of getting the CIS popup I got a misleading Windows error message saying I wasn’t authorized to run the program. In hindsight, running it in training mode would have been best, but I was in a hurry so I just shut down Def+ altogether and ran it that way. At least I’ll know next time what the proper procedure is. Merci beaucoup!