BLOCK starting up as my home page

Tnis link opens EVERY TIME I START UP my laptop first thing in the morning even though I have changed my home page and later, when I click on home, my home page opens. Why can’t I eliminate this site and stop it from opening every day, is it obligatory with Comodo Dragon? If it is, I will be eliminating Comodo Dragon as my browser because I do not feel safe with this obligatory site opening when I start browsing. ??? ??? ???

How can I stop my laptop from starting up with this home page browser when I have set it to another?

I have looked at the set up and set my preferences there but it STILL opens at search.easy
I am not an IT programmer or anything like that, I just use the browser and have never had such a problem before. I do NOT feel that my privacy is being respected with such an issue and will stop using Comodo if this cannot be resolved. Thanks for any advice.


Comodo Dragon is not associated with
The seems to be produced by a malware application installed on your system. You should install an anti-malware software and run some scans.


comodo does not set your homepage to it must be a remnant of some adware you had/have installed. You can try running malwarebytes free and hitmanpro to see if they find an infection, let us know what they find

im going to merge this with your other post since it doesnt have to do with Comodo dragon

Thank you for your help as I couldn’t fathom out how to use this forum or where to post my problem.
I am scanning my laptop now to see if I can find any malware :slight_smile: <3 <3

Hi brightlight4,
Not forgetting your previous replies.
Home button page is under Appearance, but you also have startup options under On startup.

What are the URLs set to under both of those settings?
Setting up your Homepage in Comodo Dragon

Hi, I have finally got it sorted out and I feel such a ■■■■ fool ??? :cry:
I tried the malware programme and couldn’t detect anything… So I went to eliminate it on the control panel and WHAT do I find??? The ■■■■ EasyLifeApp, which must have been installed with some other download without my having seen it. So I have Eliminated it and imagine that is the problem solved :-TU I will reboot later and let you know, as I am translating at the moment.

MANY thanks for your help, seems I won’t need the HitmanPro after all

Byeeeeeeeeeeee for now,

Eileen (:WAV) (:WAV)

Don’t feel like a fool, Programs & Features is the first place we all should have thought of looking in. :wink:
Glad to hear it appears to be removed. :-TU