blender and defence+

hi i am using blender (http://www.blender.org/) and comodo cis under windows 7 x64.

whenever i try to launch blender i get a comodo defence + alert saying that blender.exe could not be recognised and is requesting unlimited access to my computer.

even if i select “always trust this file or package”, add blender.exe to my trusted files or add blender as a trusted application in the defence + computer security policy i continue to get the same message on every launch of the program, which is mighty annoying to say the least.

can anyone offer a solution? i would be very grateful :smiley:

[attachment deleted by admin]

Yes, go to Defense+ tab → Computer Security Policy → Add → Select → Browse → browse to the Blender.exe and Use a Predefined Policy: Installer or Updater → Apply.

thanks for the quick reply.

it does seem a little odd that this program should need to be set to run as a installer all the time.

Since CIS now recognizes applications by file hash, if an application changes itself in any way during the course of normal operation, CIS will see it as a new unrecognized file each time it runs.

Currently, giving these types of applications the Installer or Updater policy is the only workaround to avoid repeated alerts.

That’s far from user friendly.

I agree. I made a wishlist post about this a long time ago…

im still unable to give the software rights to run without popping up these annoying messages :-TD

i also try to build blender, but because of comodo it doesnt work because it blocks a lot of processes and whatever i tell comodo to ignore, it keeps ignoring the ignores, how pathetic is that?
how do i set up comodo for a development environment so it does not block temporary files that are generated by visual studio?

this is a real show stopper for me next to the new gui:/

uninstalling till i get some help here, i rather go unprotected than not going at all. shame on you comodo

Did you try using the Installer/Updater policy as suggested?

Here is what WORKED for me to make Comodo accept using Blender without those annoying warnings every time.

Caution, use this at your own risk; I am not responsible in any way for your security!

  1. Go to: Advanced Settings → Defense+ → HIPS → Behavior Blocker
  2. Check the box that says “Define exclusions for behavior blocking”
  3. This will enable the “Exclusions” link. Click on it.
  4. Click on the little grey arrow that points upward on the bottom of that window.
    a. Click add…
    b. I added the following:
    for files I added
    C:\Program Files\Blender Foundation\Blender\blender-app.exe
    C:\Program Files\Blender Foundation\Blender\blender.exe
    for folders I added:
    C:\Program Files\Blender Foundation*
    c. Leave those “Exclude child processes” things unchecked.
  5. There may be a better way to do this.
  6. Hopefully someone here who knows more about Comodo can confirm that this solution is safe and not detrimental to security in any way. Note, I have been using Blender Foundation’s Blender for long enough to know that it is plenty safe to use, therefore can be whitelisted.

If this can be confirmed as safe, will a moderator please mark this issue as solved?

I hope this helps anyone out there using this really great free product.