Bizzare email notification issue

I run scripts from the command line in the following order without modification.

  1. Full backup → completes, email sent
  2. Incremental backup, using full backup (1) above as parent → completes, email sent
  3. Incremental backup, using incremental backup (2) above as parent → completes, no email sent

06.01.2011 21:20:40 Creating New Backup…
06.01.2011 21:20:40 Opening parent backup…
06.01.2011 21:20:40 Opening backup file \backup_INC_NO_0000000001_06_01_2011.cbu
06.01.2011 21:20:40 Creating incremental backup “\backup_INC_NO_0000000002_06_01_2011.cbu”
06.01.2011 21:20:40 Collecting information…
06.01.2011 21:20:40 This might take a few minutes depending of the number of files and folders…
06.01.2011 21:20:40 Writing initial items information…
06.01.2011 21:20:40 Reading parent backup information…
06.01.2011 21:20:40 Comparing incremental information…
06.01.2011 21:20:40 Writing items content…
06.01.2011 21:20:41 Writing indexation…
06.01.2011 21:20:41 Items backup is complete.
06.01.2011 21:20:41 Backup Process Complete
06.01.2011 21:20:43 Unable to send notification email because 30

Ah yes, that well known reason, “30”. Additional incremental script runs also fail to email because of “30”. Any particular reason why email can be sent in step (3)? Same script as in step (2) when it worked. The only difference is the use of an incremental versus full backup as the parent.

Error 30 means write error.
For emails, data could not be sent to email server.
Maybe some firewall settings are blocking emails.


Kinda the point of the longer explanation. Emails clearly can be sent or they would have failed in steps 1 & 2 as well. So its not firewall settings. Also if step 2 works, why not step 3? Its the same script afterall.

Checking the email settings was the first thing I did, hence constructing the text case above to show it can’t be the email settings or firewall. These steps are repeatable not intermittent. Hence I am more dispose to cry “BUG”!

Please investigate the things that is consistently different between steps 2 and 3?



Does the same issue occur if you set a scheduled backup instead of using scripts?
Is there is a limit on smtp server regarding how many emails can be sent?
You can try to change the smtp server.


There are additional issues preventing me running this job as a scheduled task.;msg479321

SMTP Server hosted by, so a commercial offering. I think doubting this SMTP server’s capabilities is looking at the least likely explanation first.


We found the cause of error code 30 for emailing.
This will be fixed in next release