Bit Tornado

How do I configure Bit Tornado in Comodo?
I’ve allowed TCP/UDP in TCP/UDP out the IP range is 0 . 0 . 0 . 0 to 255 . 255 . 255 . 255,
port range is 0-65535 yet I am still considered ‘not connectable’.
I can upload and download but the light stays yellow.

Thanks…

JJ 8)

You should add a rule at Network monitor:
Security → Network Monitor - > add rule
Action = Allow
Protocol = TCP/UDP
Direction = In
Source IP = Any
Remote IP = Your IP (pay attention if you are behind a router to use your computer internal IP and not the Internet IP of the router)
Source port = Any
Remote port = the port that your Bit Tornado client uses for connecting

Then move the rule up, over the default block rule
Hope it helped :smiley:

Thanks pandlouk. ;D
Does it matter that I have ADSL broadband, I mean will my IP be the same all the time?

Cheers

JJ 8)

If you are behind a router it doesn’t matter.
But if you use a normal adsl modem most probably your IP will change every time you disconnect and reconnect from internet. Just take a look at your new IP adress and change the remote IP on the rule you created with the new one. (it is a bit annoying but I don’t know if there is another way)

I dont have a router. :wink:

I used your rule but I find I’m still unconnectable. I have set the remote port between 49152 - 65535. Someone is on port 52104 and can’t connect. The message I get from the sites tracker is-‘stealth firewalled or overloaded bandwidth.’ Now there is only one peer and I’ve finished the download so it can’t be overloaded.

This is what the site says about connectivity…

Why am I listed as not connectable? (port xxx.xxx.xxx.xxx) (And why should I care?)

The tracker has determined that you are firewalled or NATed and cannot accept incoming connections.

This means that other peers in the swarm will be unable to connect to you, only you to them. Even worse, if two peers are both in this state they will not be able to connect at all. This has obviously a detrimental effect on the overall speed.

The way to solve the problem involves opening the ports used for incoming connections (the same range you defined in your client) on the firewall.

OK, here’s the log files for today when I started Bit Tornado…

Date/Time :2006-05-16 07:12:44
Severity :Medium
Reporter :Network Monitor
Description: Inbound Policy Violation (Access Denied, IP = 172.xxxxxxxxxx, Port = 1032)
Protocol: UDP Incoming
Source: 221.xxxxxxxxx:56537
Remote: 172.xxxxxxxxx:1032
Reason: Network Control Rule ID = 3

Date/Time :2006-05-16 07:10:24
Severity :Medium
Reporter :Network Monitor
Description: Inbound Policy Violation (Access Denied, IP = 172.xxxxxxxx, Port = 50001)
Protocol: TCP Incoming
Source: 193.xxxxxxxxx:38962
Remote: 172.xxxxxxxxx:50001
TCP Flags: SYN
Reason: Network Control Rule ID = 3

Date/Time :2006-05-16 07:03:19
Severity :Medium
Reporter :Network Monitor
Description: Inbound Policy Violation (Access Denied, IP = 172.xxxxxxxxx, Port = 11560)
Protocol: TCP Incoming
Source: 24.xxxxxxx:2132
Remote: 172.xxxxxxxxx:11560
TCP Flags: SYN
Reason: Network Control Rule ID = 3

Date/Time :2006-05-16 07:03:14
Severity :Medium
Reporter :Network Monitor
Description: Inbound Policy Violation (Access Denied, IP = 172.xxxxxxxxxx, Port = 11560)
Protocol: TCP Incoming
Source: 24.xxxxxxxx:2132
Remote: 172.xxxxxxxxx:11560
TCP Flags: SYN
Reason: Network Control Rule ID = 3

Date/Time :2006-05-16 07:03:14
Severity :Medium
Reporter :Network Monitor
Description: Inbound Policy Violation (Access Denied, IP = 172.xxxxxxxxx, Port = 1028)
Protocol: UDP Incoming
Source: 214.xxxxxxxx:28452
Remote: 172.xxxxxxxxx:1028
Reason: Network Control Rule ID = 3

Date/Time :2006-05-16 07:03:09
Severity :Medium
Reporter :Network Monitor
Description: Inbound Policy Violation (Access Denied, IP = 172.xxxxxxxxxx, Port = 11560)
Protocol: TCP Incoming
Source: 24.xxxxxxxx:2132
Remote: 172.xxxxxxxxx:11560
TCP Flags: SYN
Reason: Network Control Rule ID = 3

Date/Time :2006-05-16 07:02:04
Severity :Medium
Reporter :Network Monitor
Description: Inbound Policy Violation (Access Denied, IP = 172.xxxxxxxxxx, Port = 1026)
Protocol: UDP Incoming
Source: 61.xxxxxxxxxx:45200
Remote: 172.xxxxxxxxxx:1026
Reason: Network Control Rule ID = 3

Date/Time :2006-05-16 06:56:09
Severity :Medium
Reporter :Network Monitor
Description:Inbound Policy Violation (Access Denied, ICMP = TIME EXCEEDED IN TRANSIT)
Protocol:ICMP Incoming
Source: 195.xxxxxxxxxx
Remote: 172.xxxxxxxxxxxxx
Message: TIME EXCEEDED IN TRANSIT
Reason: Network Control Rule ID = 3

Date/Time :2006-05-16 06:56:04
Severity :Medium
Reporter :Network Monitor
Description:Inbound Policy Violation (Access Denied, ICMP = TIME EXCEEDED IN TRANSIT)
Protocol:ICMP Incoming
Source: 195.xxxxxxxxx
Remote: 172.xxxxxxxxxx
Message: TIME EXCEEDED IN TRANSIT
Reason: Network Control Rule ID = 3

I have the same problem with azureus, DHT Firewalled, and maybe with emule too !
I have made a rule at Network monitor:

Action = Allow
Protocol = TCP/UDP
Direction = In
Source IP = Any
Remote IP = Any instead of your IP
Source port = Any
Remote port = the port that I use with Azureus

and now seems to go, I hope that this is the solution !

After made the rule, restart Bit Tornado !

This is a common log when I use Bit Tornado;

TCP Flags: SYN
Reason: Network Control Rule ID = 3

My rule ID = 3 is the last one, the block all one.

Is the SYN flag anything to do with the TCP and UDP flood settings in ‘Advanced Security Configuration’?

Strange.

  1. Are you using encryption? If yes maybe this is the problem. Try to disable and see what happens.
  2. If you do not use encryption, try to check if on bit tornado is enabled the option UPNP. If it is, disable it and restart the program, and check again.
  3. If it does not work try the next:
    Change the rule: protocol = TCP/UDP ,to protocol = IP

Will try and post the results.

Thanks…

JJ 8)

Hi all,

While trying to see what is happening, we have addressed a simple bug in CPF’s network engine and fixed it. Tomorrow we will be issuing a small update for the bug and after the update, i will write the correct configuration options here.

Thank you for the cooperation,

Egemen

Thank you egemen. You guys are quick at sorting the problems. ;D

JJ 8)

Thanks for keeping us informed Egemen. It’s nice to see that the support team, really supports us. Thanks again guys :smiley:

Has the update happened?

We missed the tuesday launch, now aiming for Thursday. Thursday looks good though.
sorry for the delays, just making sure there are no glaring bugs.

Melih

Thats cool.

Thanks Melih.

JJ 8)

Bit Tornado now works and I am seen as connectable.
Great work people…

JJ 8)

Patience Jake. They might not get things fixed in the blink of an eye, but Comodo really respond to what users want.

ewen :slight_smile:

Patience is a virtue. Especially with software development and Comodo are certainly quick with responses to any problems - so requires little patience.
(L)

i fixed my nat problem in azureus using that rule aswell thnx. but the rule that we made isn’t application specific so when azureus is closed wouldn’t that port be accessible from internet?