Big step from ZA to Comodo. Got LAN problem now.

Had a small LAN of 3 or 4 PCs since Windows 95 days. Most of that time used Zone Alarm Free firewall.
The version of ZA I like to use will not install in Windows 8 (8 currently on just one machine, rest are 7).
So, I installed Comodo CIS (just the firewall) on all PCs. Looks good but relatively complicated.

Then I got freaked by ‘out of blue’ demands from Windows Security for Username and Password each time I tried to access files or folders on the other PCs. Never used passwords before on home network.

I made matching Username and Password on each machine in effort to comply but the process will only rarely accept the info I enter. Mostly I just get a repeated demand claiming a Username and Password error.

I uninstalled Comodo CIS to see if this returned the situation to the familiar one but no. Still get demands for Username and Password.

Searched this forum and Google in general for answers. Didn’t find much except an old reference on Tom’s Hardware. This was a Comodo related “Windows Run Command” where the advice was to uncheck “control userpasswords2”. I can’t find this in the current config of Comodo CIS though.

Please help.


Do the other computers have a password set when logging on to their user accounts?

The following is to cover some bases to make sure no left over of previously installed security solutions are still around.

First run the clean up tool for Zone Alarm just to be sure there is no driver or service left of it. You can find a download link here: ESET Knowledgebase .

Then run the unofficial CIS cleanup tool in Windows Safe Mode.

If you had other security program installed in the past please run their clean up tools just to be sure there are no more traces of them left.

edit:fixed url link

Thanks for the reply Eric,
Right now all three computers have the same User and Passwords set in an attempt to overcome this problem.

Based on your advice I’ve:

Cleaned away ZoneAlarm with the tool you recommend.

Run the official CIS cleanup tool in safe mode.


Reinstalled CIS (firewall only, as I have Avast! anti-virus software running).

Configured CIS Firewall based on the instructions on Gizmo’s web pages.

After these actions I’m still getting asked for Username and Password when I try to access files on other PCs and still getting told it’s the wrong Username and Password most times.


I am not experienced with handling sharing files/folders with other computers over the local network so I will only try to use my common sense to the best of my abilities trying to get the situation analyzed as clear as possible.

Do you only get the password and username request when logging on from Windows 8 to the Windows 7 boxes? Does this also happen when accessing the one Win 7 pc from another Win 7 pc? If so, when did it start to happen. What happens when you want to access the Win 8 pc from a Win 7 pc?

Did you make other changes to your computers around the time you installed CIS on your Win 8? Think Windows updates or installed other programs. The Win 7 computers still use ZA?

I asked the other mods to take a look at your problem.

Sounds like the prollem may be password protected sharing configured on the Win8 box. How ZA used to handle that is a big dunno.

Try out what is suggested at the above link and see how you get on with that.

Thanks very much Eric. I’ve been on this problem for days. Read of many solutions, tried them, no change.
Uninstalled, cleaned, reinstalled all the various suspects. Access comes back sometimes, then is gone again.
I’ll keep plodding on with trying to solve the Windows problem and if I continue to get nowhere, I’ll give Ubuntu a try.



Thanks that’s one possible solution to the problem I keep trying on each run through the list.
Maybe one time, in some combination it will do the trick.



you said:

I uninstalled Comodo CIS to see if this returned the situation to the familiar one but no. Still get demands for Username and Password.

Doesn’t sound like CIS prollem. Do ya get password challenge Win7 to Win7 box?

Of course it can be something REALLY simple, e.g.,

1.from the Control Panel, select homegroup and sharing options → Change advanced sharing settings

2.Set these options under Home or Work(current profile):

•public folder sharing [turn on]
•Password protected sharing [turn on]
•homegroup connections [use user accounts and passwords]

The homegroup connections option is where the magic happens. All of your personal computers need to have this enabled. You don’t need to reset your PC to get it to work, only to log out and log back in, which Windows will automatically prompt you to do.

Considering the awful complicated mess I’ve been working my way through, it WAS something really simple.
I replaced my router and sharing sprung into its familiar shape.

Now all I need to do is work out what setting or glitch on the router caused the sharing problem after so many years of trouble free interaction between computers.