Behavior blocker menu missing in Advanced Settings [V6][M369]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?: Yes i can reproduce the problem 100%
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened: I install fresh windows xp x64 sp2 and install COMODO Internet Security 6.1.275152.2801
  • If not obvious, what U expected to happen: I expected that installed all modules
  • If a software compatibility problem have U tried the conflict FAQ?: I read the FAQ and it did not seem to apply to this issue.
  • Any software except CIS/OS involved? If so - name, & exact version: windows xp x64 SP2
  • Any other information, eg your guess at the cause, how U tried to fix it etc: reinstall cis and windows.
  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware)
    [/ol]

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: COMODO Internet Security 6.1.275152.2801 configuration does not matter. All you need to do is install cis in windows xp x64 sp2

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: All default
  • Have U made any other changes to the default config? (egs here.): No
  • Have U updated (without uninstall) from a CIS 5?: No
    [li]if so, have U tried a a clean reinstall - if not please do?:
    [/li]- Have U imported a config from a previous version of CIS: No
    [li]if so, have U tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used: Windows XP Professional x64 SP2 (build 3790.srv03_sp2_qfe.100324-1618) Account - Administrator, Mod edit: By PM VM=Vbox
  • Other security/s’box software a) currently installed b) installed since OS: a=No b=No
    [/ol]

[attachment deleted by admin]

Thank you very much for your issue report.

We would very much appreciate it if you would be kind enough to edit your report to put it in the standard format and add any additional information requested, as this will make it much easier for the developers to diagnose and fix the problem.

The reasons we need all the information in the format, though they may not seem directly relevant to the issue are explained here.

If you are able to do this we will forward this post to the format verified board, where it is more likely to get looked at by developers. You can find assistance using red links in the format and here. If you need further help please ask a mod. If you do not add the information after a day or two we will forward this post to the non-format board. If this happens we will tell you how to rectify this if you wish to.

In the current process we will normally leave it up to you whether you want to make a report in standard format or not. However we may remind you if we think a bug of particular importance.

Many thanks again

Mouse

PM reminder sent

Thanks for adding the information.

During our PM’s in relation to this bug you said that you were using VBox VM software to test CIS. Unfortunately there is a known and possibly unresolvable incompatibility between Vbox and CIS, so if this problem is not reproducible outside Vbox devs may not address it.

I am sorry about this. Can you reproduce this outside VBox?

However this is now in standard format so I will forward it, but not yet add it to the mod’s tracker.

Best wishes

Mouse

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again

Mouse

Yes i reproduce this outside VBox.

Wierd - maybe it’s XP sp2-specific issue?

previous version 6.0 worked fine
attach an attachment with the real system

[attachment deleted by admin]

Hi Mouse and Speede,
I just tested CIS V 6.1.275152.2801 on my XP SP2, one notable difference is mine is a 32-Bit.
Sorry it is not replicated here.

One thing I would like to point out is that it appears that not only BB is missing, but Speedes Sandbox and Virtual Kiosk also appears to be totally missing.

Yes is totally missing (Sandbox, Virtual Kiosk,Behavior blocker)
XP SP2 and XP X64 SP2 is too difference, for x64 last is sp2

Hi Speede,
Without being to alarming, you really have consider how secure the system is with some of CIS modules and components missing.
Let us hope this is resolved sooner rather than later. :slight_smile:

Agreed you may want to revert to a previous version, but maybe see if QA want you to carry out any tests frst, if you are happy with this.

On the diagnosis I think this is looking like an XP x64 issue. Indeed there was a point when CIS did not really support XP x64 I seem to remember? But I have not heard anything about that recently…

You have done very well with your attachments, but I was wondering if adding you config file might tell us more.

(@QA I have validated from diagnostics that the OP is correct instating that he is on IS config)

It is currently suppose to support XP 64-bit.

Windows XP (Both 32-bit and 64-bit versions)
[url=http://help.comodo.com/topic-72-1-451-4687-System-Requirements.html]System requirements[/url]

Thanks Captain, that’s very helpful

Mike

Just a thought

Speede when you tested outside Vbox was it on a machine with VBox installed? (ie on the VBox host machine?). I assume it was an XP x64 box?

If so would you be willing to test with Vbox totally uninstalled. (Vmware Player, works great and is free, and (tip) if you install the trial paid version, when it downgrades you it leaves some of the paid for tools behind - eg the networking config utilities)

I tested with clear system there a not installed vbox on the work. and tested at home in the vbox.

Was it also XP x64?

Yes

Ta seems likely this is an XP x64 problem then