Battlefield 2 and Comodo.

I’ve tried searching but can’t find anything that sorts out my problem.

I can’t get BF2 to work with Comodo.

I can’t connect to any servers when the firewall is enabled, but when I disable it I can. In the application monitor I’ve allowed BF2 to access TCP/UDP information out and in.

I also tried to follow this tutorial (http://portforward.com/english/rout...efield_2In.htm), but my Comodo firewall won’t let me input destination ports with a hyphen between them.

Can anyone help?

If you’re using the “Set of Ports” option under the Destination Ports tab, you’ll separate with a “,” (comma) and no spaces. So it would be like this: 56473,57869,61006 (for example).

LM

According to the Portforwarding article I’m supposed to open:-

80,4711,18060,28910,29900-29901,29920

for TCP ports, and:-

1500-4999,16567,18060,27900-27901,29900,29910,55123-55124,55215

for UDP ports.

How will I go about doing this? Do I need to make a load of Network Control Rules?

If you have a router, obviously you need to set up port forwarding there as well.

Based on the PortForward info, for CFP you would do as follows:

Open Network Monitor.

The rules filter from the top down, until they are either allowed or denied. You should not already have any In rules for TCP/UDP, so by default the bottom Block & Log IP In/Out would stop them. Thus, you will:

Right-click the bottom Block & Log rule, select Add/Add Before. This will open a rules creation/editing window. You will input as the following:

Action: Allow
Protocol: TCP
Direction: In
Source IP: Any
Destination IP: Any, or your external IP address
Source Port: Any
Destination Port: 80,4711,18060,28910,29900,29901,29920
OK.

Then do the right-click, Add/Add Before again, for this rule:

Action: Allow
Protocol: UDP
Direction: In
Source IP: Any
Destination IP: Any, or your external IP address
Source Port: Any
Destination Port: Range of Ports: 1500 - 4999
OK.

That takes care of the UDP range at the first of the UDP port list. Now for the rest, do the Add/Add Before bit again, then:

Action: Allow
Protocol: UDP
Direction: In
Source IP: Any
Destination IP: Any, or your external IP address
Source Port: Any
Destination Port: Set of Ports: 16567,18060,27900,27901,29900,29910,55123-55124,55215
OK, then reboot.

I’m not a gamer, but this looks like a lot of ports to be setting up in NetMon. Thus, I would want to “match” the rules for the application as well.

Your basic BF2 executable will be fine for Outbound with this rule:

Application: the bf2 executable
Parent: Learn the Parent
Action: Allow
Protocol: TCP/UDP
Direction: Out
Source: Any
Destination: Any
Miscellaneous: leave it blank
OK.

Then you will create three Inbound rules for this executable, with Learn the Parent, which will look just like the three NetMon rules we already did. You just won’t be have a Source IP or Port; it’s all Destination, on the application end of it. Also, you’ll leave the Miscellaneous tab blank/empty on each one.

This way, BF2 is authorized to listen on those ports, so that it can accept the incoming traffic.

Got questions? Just ask.

LM