Basic opening of ports

I would like to believe that I am 100% capable of settings what ports should be open for my applications to work (specifically Azureus and Warcraft III). I have done it before, and everything was working great… until I reformatted. Before I reformatted I was using ZoneAlarm, and had it configured just right. I installed it again after the format, and could never get it to work. I know the problem was my firewall, because when I disabled it, both of those programs worked perfectly.

By the way… I am on wireless and I do have the ports forwarded to my local IP.

So ZoneAlarm wasn’t working out, and now I’m trying out Comodo.

As far as I know, and from reading some other posts…

For Azureus, I need my specific port (21478) TCP and UDP allowed IN, and everything else allowed OUT.

For WCIII, I need TCP 6112 IN, and TCP 6112-6119 OUT.

However, this configuration isn’t working. ???

Any light bulbs turn on in your head?

In addition to the Network Monitor rules to open ports, you also need Application Monitor rules to allow specific applications to receive data on those ports.
For Azureus, assuming you already setup the Network Monitor rules, you need to have an Application Monitor rule that allows TCP/UDP IN on port 21478 as well.

More on this in the FAQs thread:

In the Application Monitor, Azureus and Warcraft III are allowed all ports in and out, and in the Network Monitor, Azureus is allowed TCP/UDP 21478 IN and Warcraft III is allowed TCP/UDP 6112 IN.

edit: after searching through some of the FAQs you left for me, I found one that said I should disable the component monitor, which I did, and it still doesn’t work

and also, I have Azureus running fine now, it’s just Warcraft III that I can’t get to work.