bases.cav almost freezes XP

Following a recent Comodo Firewall update on a previously long time stable XP installation the system virtually froze once the desktop loaded at boot. None of the installed applications worked and browsers (Firefox & IE) failed to function despite appearing in task Manager. If left for a prolonged period (10 minutes or more applications started to work.
Removal of Comodo and AV (Avast) and re-installation failed to resolve the problem.
However, deletion of the Comodo files “bases.cav” restored normal function.
Are these files related to AV and if so why are they present in the Firewall only version of Comodo.?
I’d be grateful for guidance on this.

The bases.cav is the file that holds the av definitions of the AV if it is installed.

It is surprising to see it playing a disturbing role. Do you recall the size of the bases.cav database? Was it around 10 MB or around 180MB?

How did you update to the latest version? Did you run the program updater from within CIS?

The bases.cav file was 9.10Mb and the update was performed via a Comodo notification.
Has an update changed the installation from firewall only to CIS?
I’ve used Avast in conjunction with Comodo Firewall for a long time without a problem.
The same problem has now been experienced on a second PC.
thanks for your help

To clarify the update procedure used - the existing Comodo installation reported that a new version was available, it was downloaded (59.7 Mb) and installed. The new version is 5.5.195786.1383. I still have the bases.cav files and may restore them to their original location to see whether the problem returns.

Here’s what happened after restoring the base.cav files to their appropriate folders (scanners & repair)

  1. Reboot time normal
  2. Firefox took 2+ minutes to respond and then only opened a blank page, waited 10 minutes but home page failed to load.
  3. A new Word document took 4+ minutes to open and a further 3 minutes before it responded to keyboard input.
  4. Other applications took several minutes to open, most failed to function.
  5. Task Manager opened but was unable to terminate any processes and could not be closed.
  6. Shutdown took 6 minutes 32 seconds.
  7. Re-booted in Safe Mode and deleted the base.cav files, thereafter the computer functioned normally.

In my experience the 9MB bases.cav that you have when updating or reinstalling is IMMEDIATELY recognized by CIS as inadequate and it starts downloading the newest 150MB+ file from the Internet–this is an annoyance of mine because I don’t want every PC to download this large file every time, so I abort and Safe Mode and copy-in the 200MB bases.cav file I have on hand and then CIS only has to do a few quick updates.

It sounds like you are not letting CIS get the bases.cav it needs to function properly? What kind of Internet connection do you have?

That Word and Firefox et al “fail to function” makes me wonder if CIS was busy in the background trying to get bases.cav updated.

Please note Firewall only.

Are these files related to AV and if so why are they present in the [b]Firewall only version [/b] of Comodo.?

When you reinstalled both again did you try with just the Firewall installed before installing the AV.


Do I need the bases.cav, if I’m only interested in using the firewall component. The internet connection is 100Mb/sec fibre ADSL.

The system functioned OK with AV only and Comodo firewall only, but not with both installed until I deleted the bases.cav files.

I now have second machine similarly affected after a Comodo update

The bases.cav holds th av definitions and is only needed when using the av.

The system functioned OK with AV only and Comodo firewall only, but not with both installed until I deleted the bases.cav files.

I now have second machine similarly affected after a Comodo update

Do I understand you correctly that when you Comodo with the AV you also had Avast running at the same time?

It is not recommended to have two security programs of the same kind running at the same time. Did you have CIS and Avast both scan for viruses at the same time?

When running Avast it is recommended to add the CIS installation folder to the Avast exceptions.

Thank you for your continued interest and support.

I’m using the free Comodo firewall and thought the Comodo AV was a component of CIS only.
However that is not the case, what differentiates the paid version CIS from the free firewall?
I’ve been using Comodo free firewall for a long time without any problems, that is until the recent update. Interestingly the updated version downloaded on the 13/07/2011 was 59.9 Mb some 74% larger than the file 34.4 Mb file downloaded on the 24/02/2011. I will uninstall the latest installation and revert back to the Feb version - and report back.

Current 59.7 Mb version (5.5.195786.1383) uninstalled and older 34.4 Mb version (5.3.176757.1236) installed - computer boots as normal and is free from previously reported problems. It can be concluded that since Feb 2011 changes to the free Comodo Firewall download has resulted in a 74% increase in the size of cfw_installer_x86.exe and produced a serious conflict with other software on the PC (probably Avast).
I chose to use what I thought was a standalone Firewall because of the generally recognised failings of all embracing internet security packages, it looks as though it’s time to move on.

The increase in size of the default installer is because it contains both the 64 bits and 32 bits installers. The individual installers are still around at the download page. They can be found in the drop down menu behind “Choose Operating System”.

As to the compatibility issues with Avast.They have been reported since v5.4 but can be easliy worked around as described. I am not an Avast user but Avast also has a sandbox like D+. Having two of them working together can also be a source of problems; it’s recommended to choose for one of them.

The bases.cav of 9 MB you see is part of the default installation of Comodo Firewall, AV or suite. When the firewall is installed it is not used. When installing the suite or just the AV CIS will download the full AV database from the web. In your case it is not used.

However it is odd it is wreaking havoc. It would be interesting to know how and if Avast AV plays a role here.

On a side note about the Comodo installers. The installers for CIS, Comodo Firewall and Comodo AV are basically the same archives in which only the installer scripts differ. After installation CIS and CAV will download the full av database.

Thank you EricJH for your detail reply. I have obviously downloaded and used the default (64 bit and 32 bit) installer. I will repeat the exercise by removing the older version and installing the latest 32 bit only version, it will be interesting to see whether the problem still exists.
thanks again for you help, it’s greatly appreciated

Well, I’ve spent the last few hours installing and uninstalling versions of Comodo Firewall and alternately disabling the sandbox in Comodo and Avast and excluding Comodo from the Avast scan.
The v5.3 of the firewall did not give rise to any problems when installed.
The latest 32 bit version froze the PC regardless of the settings in Avast, that is until D+ was disabled, after which everything worked OK.
The firewall was uninstalled yet again and the registry “cleaned” using jv16 before re-installation, everything now appears to be OK - D+ is in “safe mode”, Avast is in default state with the Sandbox enabled and no exclusion set for Comodo. It looks as though the registry clean has resolved the problem, unfortunately the precise cause of the problem has not been identified.
Many thanks EricJH for your help.

Glad you fixed the problem. That’s what counts.