Bare Metal recovery issue

I’ve got a full disk (MBR, partitions, etc) CBU file that I’m trying to use to recover the hard drive for my wife’s laptop. She dropped the machine down the stairs killing the hard drive but the rest of the machine seems fine. So, I bought an identical hard drive for the machine and installed it.

I’ve got a WinPE boot CD and an external USB connected hard drive (E:) that contains the CBU file (so I don’t need network access during the restore) along with the Comodo Backup directory. When I use this command line:

CBU.exe /restore_operation /backupfiledestination “E:\Disk_0_full_disk.cbu” /destinationtype 1 /restorelocation disk0

I get this series of messages in the status window:

Opening backup file…
Opening backup file E:\Disk_0_full_disk.cbu
Initiating Restore Operation…
Locking Volumes on Disk…
Error Occurred.
Recover process failed with code 67
The restore process has encountered an error

An error 67 is typically a “File not found” sort of error but the CBU file is where I say it is. Any idea what the issue might be? I’ve tried the process with the laptop’s internal hard drive formatted and unformatted. Same error both times.


This is an issue with Comodo BackUp which will be fixed with the next release.
You can use right click → CBU mount option to recover specific files & folders from backup (this doesn’t work from WinPE boot CD).


So, I can’t recover the system, just files? If that’s the case, it’s a major issue. It makes the system backup option useless. Maybe I’m misunderstanding your answer…

If I install an OS on the machine could I then do a full system restore over the top of that?

OK, tried installing an OS and still get the original problem with the GUI. The command line doesn’t seem to do anything of merit but I’ll check that again.

Will these issue be fixed in the short term or should I write off the ‘full’ backup that I put faith in?

Yes, this issue is already fixed and a new release will come out in a few weeks.
I hope this is a short term for you.


So, the full backup is a complete loss. I think you should disable the option in the interface if it’s not usable at the moment otherwise you’re giving a user false hope.

I tried to mount the CBU and that didn’t seem to work either. I get a prompt to format a new drive but neither answer (yes to format or no to not) yields good results since the resultant drive is supposedly read-only.

Error 67 happens in rare cases, so the option will be kept.
The backup will be restorable once the new version of CB is out, the mount issue will be fixed then too.


Vince, he is not saying your systemwide backup is useless…it is just not working with current release of Comodo Back Up.

You have the choice: do a file by file recovery NOW; or wait a few weeks when this error is fixed in a newer update of CBU.

It is up to you how long you can wait…

Well, I have to reinstall the OS, apps & such which is what I was trying to avoid by doing the full system backup. So, the functionality seems a bit lacking. I couldn’t mount the backup either to get files out of it but I’ll give that a shot later.


I have encountered the same problem while just checking functionality and reliability of CBU hence, for total system backup (image of the drive) I have crossed out CBU from the list and WILL stay with Snapshot Disk Imaging. I have used it for the past three years and it has been extremely reliable with no problems at all. Although not free, but a few dollars to spend to have a reliable total system image available will pay off the first time you do a restore. A trial version is free. You may even include it in a BartPE boot disk hence eliminating the need to install OS before retrieving the image.

Hopefully the next version(s) of CBU will be a bit more accurate and dependable with all the features working as expected. Total system and OS backup should be reliable with NO exception.


So when is the next release going to be available?

Which one? (public) (beta)