Backups not running

My scheduled backups don’t seem to be working in the background. The only way I can get them to fire off is if I manually start them. I looked in the windows task scheduler and there is nothing comodo related.

At the time the backup is scheduled to start no icons show up in the task bar notification area (Windows 7 Pro x64) all icons are set to show all. ( I don’t think thats a feature but if not it might be a good idea for users to reference there the backup job is actually happening).

Missed scheduled backups are set to run at the first chance and run mode is set to Service Run, but again no backups are taking place ???

Not sure if I missed any steps in the configuration… any help would be apperciated.

Is anyone experiencing the same issue ? How are you backups configured ?


What type of schedule did you select? (daily, weekly, etc)?
Please collect the debug information after the schedule is supposed to run, so we can determine cause of the problem.


I am trying to run daily differentials… weekly incrementals and monthly fulls. The only that I have been able to get successful backups was to use the Windows Task Scheduler to execute cbu.exe at 30 seconds prior to the backup schedule in Comodo Backup. If that is not running no backups will work. Is the Windows Scheduler needed to configure backups by design ? I will send you the logs as requested.

Debug info is attached. Thanks !

[attachment deleted by admin]

Also got this error…see attached.

[attachment deleted by admin]

For Service mode runs, Windows Scheduler is not required.


The debug information doesn’t contain “\Windows\Temp\ComodoLogsFolder” debug information where the Comodo Backup services write their logs. Is the Windows Temp location changed/customized?


No everything is in the default windows locations.

Withouth using windows scheduler to trigger CBU.exe no backups will run. It seems like there is an issue with the CBU scheduler. I’ve tried this on both Win 7 x64 and x86 machines. Neither work.

Are there any files named “SynchronizationService.exe.log” and “SynchronizationService.exe.logold.log”? If so, please collect and post them after the schedule is supposed to run.


Does this happen if you immediately start the program after system start up?
If yes, the issue will be fixed in next release.

Files are zipped and attached. Thanks !

[attachment deleted by admin]

That error only happens sometimes when I start the application. Most times it does not happen at all.

Here is interesting stuff from the log:

[03.10.2012 22:31:02:781|000381|__internCBUWriteLog] CBUWriteLog: 03.10.2012 22:31:02 Running scheduled backup Christopher_dif_files|REVISION_NO_MAX06||DATE2.cbu
[03.10.2012 22:31:02:781|000381|__internCBUWriteLog] CBUWriteLog: 03.10.2012 22:31:02 Creating New Backup…
[03.10.2012 22:31:02:812|001178|CoreQueryDirectory] FindFirstFile for \?\UNC\MEDIACENTER\Chris\Laptop\Backups\Vostro Backups* error system error 5
[03.10.2012 22:31:02:843|000381|__internCBUWriteLog] CBUWriteLog: 03.10.2012 22:31:02 Opening backup file \MEDIACENTER\Chris\Laptop\Backups\Vostro Backups\Christopher_dif_filesREV_NO_000000000110_03_2012.cbu
[03.10.2012 22:31:02:859|030857|DeleteIncrementalAndDifferentialTreeForBackup] Opening \MEDIACENTER\Chris\Laptop\Backups\Vostro Backups\Christopher_dif_filesREV_NO_000000000110_03_2012.cbu error 55
[03.10.2012 22:31:02:859|000381|__internCBUWriteLog] CBUWriteLog: 03.10.2012 22:31:02 Creating full backup “\MEDIACENTER\Chris\Laptop\Backups\Vostro Backups\Christopher_dif_filesREV_NO_000000000110_03_2012.cbu”
[03.10.2012 22:31:02:921|004341|CreateNewFileBackupOnNetwork] Cannot perform requested operation because 55
[03.10.2012 22:31:02:921|023626|CreateNewBackup] Create new backup failed because 55
[03.10.2012 22:31:02:937|012282|_BACKUP_CREATE::StartBackup] Backup process failed because 55

System error 5, which is the same as CB error 55 means “access denied”.
This, most frequently happens, when a user doesn’t have enough privileges to access that file/folder due to NTFS security attributes limitations.
When you run the backup process manually you don’t get this error because you have enough privileges.
But when you set the task to run as service, it runs as “SYSTEM” user and it doesn’t have enough privileges.


Something that is even more funny…when i setup windows scheduler to trigger CBU.exe about 1 minute prior to the start of the CB scheduler, I’ve tried to run the windows task scheduler as “System” and have also tried to run it as my username. Ive had more success with running it as me then as system, but neither have been consistant yet. The only consistant way to get backups is to actually have the CB application open when I am logged in.

Also home come ther is no tray icon when the backup is running. That would be extremely helpful as an indicator to the user that there backups are running. I know I currently have to browse to the network location and look at the time/date stamp of the back file and log to see if it is running.

Here is an article that may shed some light :
It seems that SYSTEM user is by design made not to access network shares.

You could avoid this by setting it not to run as service mode, but silence mode, and edit the task in Windows Task scheduler to run whether you are logged in or not.


I run the task in windows task scheduler as my username, however as you had mentioned in an earlier post this is not needed by design. So the question remains, what is wrong with the CB scheduler, what is causing that not to work properly to take care of the scheduling, and most importantly how do I get it to work as designed.

In the log files CB does run a check to see if the windows task scheduler is working properly or not, so if CB is running indepdent of windows task scheduler why does it run a check up against that ?

As I explaied earlier, the issue is not with CB scheduler. The schedule starts to run as it should (in service mode) at the scheduled time, but, when running in service mode, the process is ran as “SYSTEM” user. “SYSTEM” user is not designed to access network shares. So, the process fails because access is denied.

Service mode backups are not designed to work on network.
To make it work, check the “run wether user is logged on or not” option and uncheck the “Do not store password […]” option. (see attached screenshot)

Service mode backups are independent of windows task scheduler. Backups that run as current user are not independent.


[attachment deleted by admin]

When I run the task as my username that is exactly how it is setup. So if I understand what your saying is to setup CB to run in silent mode and only use the CB task scheduler and not the windows task scheduler. I will setup a backup to test this way and let you know the results.

Can I make a feature request to have an animated tray icon appear when the backups are running so users are aware that there backups are working properly.

Also I noticed that on my PC the desktop icon has the UAC shield on it and several other machines that I have do not…whats the reason for the icon. Ive attached an image.

[attachment deleted by admin]