Backup with Files/Folders Selected Never Finishes Calculating Time Step

I have had success with full drive backups. That seems to work fine.

I have not been able to get the backup with files/folders selected to work. It appears to hang at the “Calculating time remaining” stage. Even if left for hours it’s the same result.

Any ideas?

Hello and Welcome dmacgreg to Comodo Forums :slight_smile:

Can you please list what version and Operating System you are currently using; and if any other Security Software Installed?



Sure. Windows 7 Professional, Using Microsoft Security Essentials.

Please select the folders for backup in explorer and click properties.
Let me know how many files & folders there are contained and their total size.


I am having the same issue. I just installed the latest Comodo backup.
Windows 7 Home Premium
Backing up “folders and files”, and clicked C: to backup whole disk.

Just as I registered and started typing, the backup started. It was on “Calculating Time Remaining” for 30 minutes and 46 seconds, and the disk light was flashing / solid the whole time. This seems a bit excessive, as I defrag that disk every month or two.

I did not have this issue on my XP SP 3 machine - it only calculated for a few minutes.

How many files and folders do you have on C: ?
You can select all in explorer and right click properties.


Selected all from the root of C:\ and did properties. Here is what it came back with:

165,368 files
27,120 folders
30.2 GB
30.6 GB on disk

This is a fairly new HP laptop - only a bit over a year old. There is not that much on it.

Before I run backups, I run a system cleaner to delete system temp files, user temp files (from all accounts), log files, etc. This step removed 650 MB of space before I started the backup.

It should take a few minutes (5 minutes at most).
In the next release the log will display in log number of files & folders found every minute to avoid the feeling that it’s frozen.