Backup will NOT work over network

Where to begin…After over a week of trying to get Comodo Backup to work, I have finally figured out the problem. It simply will NOT perform a scheduled backup over a network.
I have Comodo Backup installed on a client computer, trying to backup from a server. I have a folder shared on the server with all my backups in it. I can access this folder just fine manually. But every single time Comodo Backup tries to perform the backup nothing happens. I read the log file and it says, “Error - Source folder does not exist !”.
But here is the funny thing, if I open Comodo Backup manually, it performs the backup just fine…
I tried backing up some local files with the scheduler just to see if it would work. And it DID?!?!

Any ideas?

Hi,

I worked on this issue for some days and one time, in a moment of rare insipiration, I said “Is it possible that I sleep so hard?”.

First of all, running a backup manually and running it as schedule event is drastically different. If you run manually, you are logged in to Windows (probably with an administrator account). I you run a backup when user is logged off (and Comodo closed), you run backup as system services (the software run in background but doesn’t need a user logged in). A service run under a user control, and you have to select which user has to use.

Comodo Backup doesn’t ask you which user has to control his system service, like, for example, NTBackup; Comodo Backup run the service as Local User, so it can’t access to network (Local User can’t).

Go to services control panel and enter in the properties of “ComodoBackupService”. Set an user with administration credentials as account for run the service. Now Comodo Backup can access to network resources in schedule mode (when running as service and user logged off).

Hope can help.

Good thinking, Sciagu! I’m glad you don’t sleep too hard… ;D

Does that help you out, jminnie?

LM

Excellent suggestion Sciagu! I am not currently at the system with Comodo Backup on it, but as soon as I can, I will give it a shot.

Thank You for your reply!!

Hi Sciagu, I tried exactly what you suggested. But now the service does not start with windows. I tried every single credential, but nothing. Am I missing something?

Hm, is that working with a domain user who has right to both computers?

jminnie,

I think you miss something because this is the exact procedure.

Let’s check the service properties and take care about the way you enter the Windows account name. You need to input in this way:

PCNAME\accountname
or
DOMAIN\accountname

Are you under a domain? Or singles computers?

The used account needs to be exactly the same (same password) on all two pcs.

Also check that the service is in “automatic” start mode.

For testing purposes, try use local Administrator account, but set the same password EXACTLY as the Administrator’s password on other pc.

Let me know more infos.

Hi Everybody,

I am not on a domain. I have the correct information entered (PCNAME\accountname), but it still does not work. And the service is set to Automatically start. The only time I can get the service to autostart with windows is when it is set to (LocalService), which I believe is where Comodo Backup set it to in the first place. I do not have a password set for this account, so I left the field blank. Though I did notice something strange. When I went back into the “General” Tab and clicked “Stop” then “Start”, a message popped up saying something along the lines of “Account information is incorrect”. But everything is correct…I am so tired of playing with this, it has been a couple of weeks now of trying everything under the sun. I think I may retire Comodo Backup for now and hope that the development team corrects this in a future revision.

Thank you to everybody for your suggestions. (:WAV)

It doesn’t seems a Comodo bug.

If Windows says something about right user/password, is the service/account that has a problem.

It’s sounds really like that user you enter is not valid, so he can’t startup the service.

Hey jminnie,

Are any of the pathes related to user only settings (ex. mapped drive) or you use backslashes (ex. \192.168.123.123\share)?

Arki

Hi… All of you
I have problem same as [ at ] TS. I have tried some methods from the users in this forum, but still no luck.
I think it’s really the BIG ISSUE/BUG for the ver 1.0.2.0. The old one ver 1.0.0.1 is OK for all with regarding this schedule issue.

The problem on automatically scheduling (type: User/Service Backup) is:

  • Source folder is local drive >>> OK :slight_smile:
  • Source folder is network map drive >>> NOT WORKING :frowning:

BUT no problem on manually run for all.

So what… next…??? I use back to old one 1.0.0.1 (V)
Still hope the good news from comodo team to release next new version. (L)

Hello bigben

I have had quite a bit of experience with Comodo Backup but using a network drive as a source with the schedule is something I have not tried. Let me work on it a bit and I will see what I can figure out. If someone else has had experience with this they may get back to you before I do.

John

Now it’s working :BNC
Network map drive is still not working (still got homework for comodo dev team). For network source folder is only now accept full path network, just scroll down to ‘My Network Places’ & go to network sharefolder (eg: \RemotePC or Server\foldershare\subfolderblabla\etc). I just remember one of the member in this forum said that must use network full path.
Therefore i do not need to install the old one 1.0.0.1. :slight_smile:

Here is the link that i read before.

Thx to above link members advice & also jjasper.

Hello bigben

Glad to see you got it working. Thanks for posting the solution, this may help others in the same situation.

John