Backup process failed with code 4


I’m configuring v2.0 on a 64-bit Vista machine to backup to a local ftp server.

When I manually run the backup, and after inputting the username/pwd, the process will create a new folder on the ftp server (so I know the connection is OK) but then fails after several seconds with the error: “Backup process failed with code 4”.

Here’s the log:
Running scheduled backup
Collecting Information…
Starting Backup Process…
Error Occurred
Backup process failed with code 4

I wasn’t able to find any information on error codes.
Thanks for your help.



Please give us more details :

  • what kind of backup it is (files and directories, disk/partition, etc)
  • is it a ‘simple copy’ backup?
  • do you have enough space on the ftp server?
  • does the error occur when you recreate the backup without scheduling?

Thank you

Thanks for your quick reply.

It’s a …
Files and directories backup.
Simple Copy
The server has about 600 GB of free space
The backup was not scheduled.

I’ve attached screen shots of the setup windows.

Thank you

[attachment deleted by admin]

Yes, this looks like a bug :slight_smile:

We will investigate the issue and come with a solution

Thank you

i have this problem too. >:(
Please rebuild this version

I too have this problem. I ran installed comodo on my lenovo desktop and the backup worked without a hitch, yet I just installed it on my brand new HP desktop and I too got the code 4 error. I proceeded to uninstall it, install it again, and it gave me the same error. I ran it as a scheduled backup and again the same error. I created a folder and again the same error. Please let me know how to rectify this situation because I am really happy with the product.


i also am getting this error, and have been unable to make a successful backup. Please help because your software seems so simple and fulfills my needs.



We will fix this issue.
You can use backup to .CBU file until the next release.

Thank you

I also have the same problem - “Backup process failed with code 4”.
The line before says “IOCTL error”.
I am trying to backup my complete C dive to an external HD using a .cbu extension (lots of free space on HD).
Vista Ultimate, 64 bit.



Can you please try the diagnose button in the settings tab.
Did you restart your computer after install when you tried to perform the backup?



I’d just downloaded Comodo backup from the Comodo Website for the first time and assumed it was the latest version. It was 2.0.8 something (I think). Clicked on “Check for updates”, installed the latest version and all is well. Great product! Thanks.

I am having the same problem with newly downloaded version 117500.10 using simple copy to another pc on local network. All shares et up correctly.


Please press “check for updates” and install the latest version.
If you still have troubles please describe the problem more detailed. Go to settings tab, press Diagnose too see if application is installed correctly.

I’m getting a similar error. Twice, I have gotten about 40 GB into a backup of my hard drive (200 GB) when the error pops up. I am running XP 32 bit. I have version 2.1.118414.11 and the diagnose button indicates that my installation is correct and I rebooted the machine before trying the backup.


We need some more information:
Does this error occurs at the begging or the end of the backup process or, does this occur during the actual backup?
What other additional security/backup software you have installed?

Thank you

The error occurs in the middle of the backup, usually after about two hours of backup time. I have PC Tools Internet Security installed on the computer.

I just downloaded the latest version (2.1.118414.11). I am getting the same error message (failed with code 4). I’m running W7, Ultimate, 64 bit. I’m trying to create a backup on a network file server, an HP MediaVault 500 GB drive, with about 250 GB free. My error occurs at the very start of the job. I navigate to my MediaVault backup folder, and then create a file called “Tom.cbu” in that folder. I then run the backup without scheduling it. It creates the following log on the screen…

Creating New Backup
Initiating Backup Operation
Gathering Information
Starting Backup Operation
Performing Backup Operation
Backup process failed with code 4

All of that happens in less than 30 seconds.

I checked the Settings / Diagnose button, and it says, “The application has been verified.”

I read the earlier suggestion to use a .cbu file, but that appears to be what I’m already using. (It’s the default selection, and that’s the extension of the file I’m creating."

So I need some help, and am stuck. It’d be great to get this working so I don’t have to buy Norton Ghost. :slight_smile:

Addendum: I tried the same process, but this time instead of specifying my network HP MediaVault drive, I chose a second hard drive in the same computer. That backup failed in exactly the same way. So it doesn’t seem to have anything to do with the MediaVault, nor anything to do with having selected “Network” instead of “My Computer.”

I too encounter this error code when backing up over FTP on LAN using Cerberus FTP on the other computer with WinXP and my machine running Win7 x64 with Comodo Firewall, CTM and avast antivirus installed. Opera, Trillian and Skype running in the background at the moment.

The error disappears when the path is changed from FTP root to some folder on the FTP server. However, despite the backup having a “success” status, a mere “empty” 2KB *.cbu file is created in the destination, making it still unusable.

CB would be such a great SW without these kinds of bugs and inconveniences that still seem to be present in some form in any chosen way of backup. Doing good, just keep it up guys and work on these bugs… Pretty please. :slight_smile:

!!! EDIT:
Oops. My bad. Let me amend the error report.

In my case, the above mentioned solution actually seems to work fine. Instead of backing up to FTP root, create a folder and make the backup into it by specifying the path like this: Folder/Backup.cbu

No error code 4 appears this way.


PS: I just wish Comodo didn’t re-write the whole backup file every time. Imagine having a 10GB backup of everything important on remote PC, then the connection failing in the middle of backup process and your hard drive going to shreds the following day. Insane! And definitely unsafe… But I’m sure you guys are already working on incremental backups… GL.


Error code 4 for disk/partition backups which occur during the backup process will be fixed in the next release.
Also incremental backups will be introduced then.

Thank you for the feedback.

Good to hear that. Can’t wait to see files being actually checked for changes instead of being copied over and over. Just note that my previous feedback concerned custom File/Directory backup.

Thank you as well! :slight_smile: