Backup from NAS to HDD

I would like to make a backup from a folder in my NAS, to the computer HDD runing the Comodo Backup.
The NAS drive is mapped with the drive letter (Z:), but in Comodo Backup it only appears the HDD drive (C:). So, this way i can´t select the source folder…

Is there anyway to solve this?
The computer is runing on Windows 7 64bits.


Is the Z drive listed in backup step 1?
If not, then probably because UAC is enabled. You can run cmd.exe as adminstrator (in \Windows\System32) and remap the Z drive. Then the drive will be visible.


Exactly, right in step 1 it only appears the (C:) drive.
In cmd, what’s the command to remap the drive?

net use z: \SomeComputer\SomeShare


It still didn´t work.
It gives error 85, it says it’s already assigned.
Still no drive Z in Comodo…

Try another letter. Y for example.
Don’t forget that cmd.exe should be run as administrator.


I’ve tried with another letter and now it gives error 86, the specified network password is not correct.
How do i put the password?

Try the following

net use t: \SomeCompuer\SomeShare /USER:UserName Password


No use, not the right command, i’ve tried several option, and none worked. :frowning:

What error did it returned?

Sorry it’s in portuguese…
nomecomputador=computer name
separado por pontos=separated by dots

Here is how it should look.
See attached screenshot.


[attachment deleted by admin]

Now it says, error 53, network path not found…
Strangely it also doesn’t appear on the windows network in explorer by default (only if i type it on the adress bar), and i’m accessing it like drive (Z:). :-\

I’ve made it with sucess on another folder (\public).
But the folder that i want to make the backup from, is like (\my documents).
I’ve tried (\xxx\my_documents) and (\xxx\my documents), but with no sucess, always showing the error 53, or the text in the screenshot i made.
Any sugestion on how to type it right, or the folder cannot have a space or 2 words?

How can i remove the drive i made with “net use”, regarding the (\public) folder?

Thank you so much, for your patiente and help.

Please see the screenshot attached. Use quotations.
To remove a network drive use the following command net use Y: /delete


[attachment deleted by admin]

Thank you! It worked. :smiley:

Just one more question.
I’ve the backup schedule for a everyday run, but everytime it gives me the error 46, so i’ve to run again the cmd command.
Do i’ve to do this everytime i turn on my computer? :frowning:

Error 46 is invalid path.
Can you please post the log of the backup operation?


I too, have problems with mounted network drives. First Comodo Backup wouldn’t see them - I remounted it with the ‘net use’ command and after that Comodo can see the drive. After rebooting things go back to “normal” (ie. can’t see the drive).

Use can use task before/after backup in Backup Step 5.
Create a bat file which mounts the drive set it to run before backup.
After backup you can use another bat file to dismount the drive.