Backup format issues

I searched the forums before posting, but some of these issues have not been reported (for CB3.0 at least).

First, a question: why has the option to compress cbu backups been removed?

Now some issues:

I am unable to mount cbu files as a drive. I tried from both the Manage screen and from the Restore screen. CB3.0 says “an error occurred” but there is no log or detailed error message. I noticed that this was reported previously in another thread.
Happily, the Restore function works correctly - I am able to browse and restore from cbu files (even compressed CB2.2 cbu files) … I just can’t use 3.0’s nifty drive mount feature.

CB3.0 appears to happily create zip files larger than 4GB which are corrupt and cannot be opened. I tried a large backup - roughly 40GB of mostly uncompressible music and video - and after a couple hours CB produced an impossibly small 4.12GB zip file. I know that zip has a 4GB limit, but a backup program should handle this intelligently, either by splitting the backup into multiple zip files or by offering Zip64 (and telling people that they need a Zip64 client to restore!).

Ditto for ISO format. I used the same 40GB … CB3.0 happily copied it all into a 40GB ISO file (which could never be burned to any media) and then failed at the finish - presumably writing the ISO directory although, again, there was only “an error occurred” with no detail. Again, a backup program should handle this intelligently, asking what kind of media the ISO is intended for and splitting the backup if it exceeds the media size.

I tested CB 3.0.171317.130.
Computer 1 is a 32-bit Pentium IV HT (threads enabled) with 4GB of RAM, XPpro SP3.
Computer 2 is a 64-bit i3-350 with 6GB of RAM, Windows 7 Home.
All OS patches for both systems are up to date.

I had the same results on both computers. I wasted several hours creating (test) backups that didn’t work. If I were a newbie and the backups were real I think it would be quite annoying - perhaps to the point of abandoning the software.

Hopefully, these issues will be addressed in a coming update. If nothing else, fail and tell the user that their backup is too large to be fit into the selected format. Meanwhile I’ll be returning to CB2.2 so I can make compressed cbu backups.


Also, I did full cbu backups of my loaded XP machine (~180GB) to an external HD. CB3.0 took over 16 hours to do the backup without compression. CB2.2 performed the same backup in under 13 hours with high compression (saving nearly 30GB of space). Apart from system services, the backup was the only program running in both cases.

Why is CB3.0 so slow?



Compression option has not been removed. CBU compression is by default low. You might set different compression rates in backup step 3.
The issues reported will be analyzed by our QA department and fixed in next release.

Our QA department is looking into this issue. It should be faster than 2.2