Backup failed with code 112030 (Internal error)

I decided to give a try to comodo backup. Since i have installed the latest version soft and started trying to backup my files, for about one week i have never succeeded in doing a complete backup. I am always getting the error:

Backup failed with code 112030 (Internal error)

Another error that comes up often is:
02.12.2013 12:40:02 Backup failed with code 100 (Timeout)
Does anyone know what do these errors mean? I have tried different files / directories, i have disabled antivirus software. The backup process always goes for 1-2% and the error stops the backup.
I am on Windows XP 32 bits.
Need to mention there were no issues backing up same files / directories using other backup solutions.
Thank you.

Hello AzMandius,

I too am a new Comodo customer who, like you, encountered CBU code 100 and internal errors (error code 112152 in my situation).

Initially I was running Comodo Backup version on Windows 7, and was told by “Geek Buddy” that the CBU version I had been instructed to install was old and held known problems i.e. there is/was a link on the Comodo new customer web page that installed a bad version of CBU.

What version of CBU are you running? If 4.2.x, then you need to update to 4.3.x, using the following URL:

With CBU 4.3.x the code 100 errors went away, but next, I began encountering undefined code 9 errors. For that troubleshooting line, refer to my “What is the undocumented error code 9 ?” thread.

The short story on internal and other errors is to troubleshoot them with dbginfo, used as shown below.

I hope that this information helps. Even with the many CBU errors and it’s poorly focused documentation, I think that once I can get it to work, it will work well. I suspect that the errors now seen in my installation resulted from my beginning to use the product in the middle of Comodo’s conversion of Online Storage to include all the cloud services (CCloud, Comodo Online Storage and C-Drive) - that conversion even caught Comodo’s own support unaware.


On my Windows 7 OS, running the current CB, I searched for dbginfo.bat, leaving the resulting MS Explorer window up, and…

Reproduce the CB problem situation, noting the time to the minute.

Right-click on dbginfo; “Run As Administrator”:
C:\Program Files\COMODO\COMODO Backup\dbginfo.bat

This produces a compressed archive of the following format:

Run the archive, bringing up the CB interface for selecting a folder to extract the archive to.

Sort the resulting log files by modification date, and review their contents by the date/time-frame of interest.

Hi erics,
Thank you for detailed reply and solution. How did you find all this out? Are you an employee at comodo, or are you using the paid version of software and getting a lot of help from support staff?

Hi AzMandius,

I am not employed by Comodo. I am a new customer who purchased Comodo Backup after giving the free 5GB CBU a work-out, read documentation, located this forum and searched through it - receiving good help from Emanuel, and opened some “Geek Buddy” support sessions. I currently have a case opened with Comodo support through email, for the code 9 issue, that has been escalated to the CBU application development team.

It is my usual approach to IT, to work through, document, communicate, and share.


I have done all that, and generated the needed error log, but the first thing i get replied with trying to get some help on those logs was:

Did you purchase our Comodo product?

How can i purchase a product that didn’t work even once since i started trying it? Are they spreading out free software with intentional bugs, to make people buy it to get tech support?

The entire scheme looks a bit weird, first i purchase a product that i already know isn’t going to work, then i get support to somehow make this product work. This is unbelievable. I guess I’ll stay away from comodo products from now on, suggesting others to do the same.

I do not think that it’s a purposeful scheme, but that it’s poorly integrated support, development, and sales operations. Still, I think that the application and it’s pricing is competitive. Given my experience with other vendors, the Comodo backup application system (support, development, and sales) seems workable/tunable.

We will see what happens with my current ticket, and you should probably open one too. If Comodo cannot get their application functional for new customers, they would soon be out of business. If they can get mine working, and they are going about that very slowly, I have a number of friends who are waiting to see what happens before purchasing.

For every one customer who speaks up, there are many more who don’t, and who usually just move on to other vendors.

OK, let’s wait and see if you’ll be able to do backups.

And by the way, the errors solving forum category has 42 pages, that means a lot of errors, and i did not really found many solutions there.

[at] AzMandius and [at] Erics,

Just a quick note to say thanks for the calm, logical approach you are both taking. From a mods perspective, It makes a genuinely refreshing change.

[at] AzMandius, yes, there are 42 pages and this would suggest there are a lot of issues with CBU. However, a very high percentage of these have been addressed through program updates and the developers do not (i.e. never ;)) post back in the thread saying a particular issue has been rectified.

[at] Erics, the CBU error codes are, apparently, a mystery best dealt with by Comodo devs only. Sometimes you have to think outside the box.

I was getting an error code 10067 (File not found). I eventually found the missing “file” was the Outlook profile registry key. I had recently installed an Outlook-Android synchronization tool and it created its own profile which was lower (alphabetically) than my original profile and therefore was placed above the native profile. CBU apparently uses the first profile, rather than a specifically named profile. Issue is now rectified.

Please bear with the developers as you work through your issues. Emmanuel and his crew know their stuff and have been a pleasure to deal with over the past couple of years.

Cheers and thanks,
Ewen :slight_smile:

Thanks for noticing our issues. I still try to figure out what error codes mean in my case? Will i ever be able to complete a single backup? Or could you perhaps just tell me what these errors indicate?

Mate, if I knew all the error codes I would be the first to publish them here. Sadly, a lot of them are, so far, undocumented.

Error code 100 is a timeout issue and is frequently seen when backing up to the cloud location. It can also be seen if you are running multiple backups across a LAN to a single destination and the times overlap.

Error code 110230 is an unknown to me.

Have you updated to the latest version, as suggested by EricS?

Ewen :slight_smile:

When did the last version of software come out? I just started to use comodo backup product about a week ago?

I’m surprised developers created error codes indications but did not publish info about them so users would know what is going wrong.

Sorry, I misread the earlier posts in this thread. If you are running V4.3.3.19 you are up to date.

I'm surprised developers created error codes indications but did not publish info about them so users would know what is going wrong.

I’m with you on that. I really want them to publish a comprehensive listing of all error codes.

Ewen :slight_smile:

I’ve just installed Comodo Backup on to a Widows 7 (64bit) machine and attempted to run my first backup to cCloud. After copying 1% of the contents of the specified folder, the process stopped with “an error occurred while writing data to backup”. On aborting the process, the message “Backup failed with code 112030” was displayed. I am running version Has any further progress been made in identifying the cause of this error?


Please try again now it should work. On December 21st, server experienced some heavy load issues which might have caused this error.


Hi, thought I’d give the cloud backup another go. Reinstalled CCloud and Comodo Backup and attempted to backup a folder structure:
31.01.2014 15:47:48 Creating New Backup…
31.01.2014 15:47:48 Deduplication is disabled because compression level is not highest.
31.01.2014 15:47:49 Cannot find a backup base. Defaulting to full backup.
31.01.2014 15:47:50 Creating full backup “/Broilers_inc_files.cbu”
31.01.2014 15:47:59 Collecting information…
31.01.2014 15:47:59 This might take a few minutes depending of the number of files and folders…
31.01.2014 15:48:01 Total items found is 1308. Total size is 670 MB
31.01.2014 15:48:01 Writing initial items information…
31.01.2014 15:48:01 Writing items content…
31.01.2014 15:48:01 Processing H:\Business\Broilers
etc …, until:
31.01.2014 15:48:09 Processing H:\Business\Broilers\Photos\Chicken Sheds Site\Site from the road looking West.wmv
31.01.2014 15:49:59 Backed up to CCloud 6.56 MB (average speed 55.9 KB/s)
31.01.2014 15:51:50 An error occurred while writing data to backup!
31.01.2014 15:56:59 Error Occurred
31.01.2014 15:56:59 Backup failed with code 33 (Invalid request).

Tried a “retry”:
31.01.2014 15:58:04 Creating New Backup…
31.01.2014 15:58:04 Deduplication is disabled because compression level is not highest.
31.01.2014 15:58:04 Searching specified backup base
31.01.2014 15:58:04 Base backup not found in original location, performing advanced search… this might take a few minutes
31.01.2014 15:58:05 Parent base not found.
31.01.2014 15:58:05 Cannot find a backup base. Defaulting to full backup.
31.01.2014 15:58:06 Creating full backup “/Broilers_inc_files.cbu”
31.01.2014 15:58:18 Error Occurred
31.01.2014 15:58:18 Backup failed with code 112152 (Internal error).
Can you help?