Azureus problems - I can't get a green smiley!

If I don’t run a firewall, I get green lights all the time - which means I have my router configured correctly. I ran Panda for a while and never could get green smilies, so I switch to Comodo, and can’t seem to get them either, and am fire walled.

Here is what I have done:

I allowed Azureus when the warning box pops up.

Then I:

Select network monitor

Click the add option and do the following:

Rule for TCP/UDP protocol
Action = Allow
Protocol = TCP or UDP
Direction = In
Source IP = Any
Destination IP = Any
Source port = Any
Destination port = (the port I’ve defined for TCP listen port and UDP listen port in Azureus)

When I’m done, I move it to the top of the list.

I’m still fire walled, and nothing I do seems to change that.

I really like Comodo, it’s much easier to use than Panda and seems to take less resources, but, darn it, I really want to get those green smilies!

Thanks,
Joe