Azureus - NAT

Hey ppl.

How are you?

I seach topics related and followed the rules for azureus port but the nat error continues. If i turn off comodo the nat disappear and torrents stayed green. Help me!


I love this fw (:LOV)

Are you behind a router?
What do the logs say?

I will write a rule that works for me, so you can try the same.
First let’s say we create a Network Monitor rule for the Azureus port.
Action : Allow
Protocol : TCP or UDP
Direction : In
Source IP : Any
Destination IP : Any (zone if you have one)
Source Port : Any
Destination Port : A single port : 52222
Move the rule up to the top of the list.
Then you should restart CPF and if it doesn’t work, you have to restart the computer.
Now you can start Azureus and go to Tools/NAT Firewall test and try the port 52222.
If you get NAT error, TRY AGAIN!
Azureus is a really slow starter, so it can take minutes before you get green light.
I always get a “Nat error” when i start it.
In Application Monitor you can set Azureus to “skip advanced…” and “Allow invisible…”
If it still doesn’t work, post your logs here.

You must disable the UPnP faeture of azureus.

For doing so open Azureus and find:

Tools → Options → Plugins → UPnP

There uncheck “Enable UPnP”


The only way for me to have both nat and dht green was to add the following rule:

Allow TCP or UDP in/out from ip any to ip any where source port is any and destination port is 47*:-65.*. [ whatever range of ports]

Is it ok ? I tried other rules but I didnt get the green things (:AGY)

Thanks both of you (AOwL and AOwL)
Keep the good work (:CLP)

arsenic you have router?
you have to open the azureus port. If you dont know. Follow this tutorial and choose your router model.


Yes thats ok, but since there is a default rule that allow all Tcp/Udp out, it seems to work for me anyway, with just In. I had the same rule as you first.
I followed Pandlouk’s suggestion even though it worked for me before. It seems that Azureus doesn’t “take over” my internet connection like before. Earlier when i have used Azureus, it was a pain to browse the web at the same time, even if i have 100Mbit/s full duplex, but now it works really good. Azureus is based on Java, and tend to be “heavy” on many computers.

Just for your knowledge, and something you can try, is that i have both “skip loopback” checked. The TCP one is unchecked because if you are using proxy you might be attacked, but if you’re not using proxy, it’s fairly safe to check that. It solves some other problems too with other programs.

I also have upnp (sp?) unchecked. skip loopback ? what would that do ?what i gain on permformance ?

uPnP used to be a big security hole, but I think MS finally plugged it. Most people still have it disabled for security reasons though. No performance hit if you disable/enable it.
Not sure what the “Skip Loopback” option is. But if it’s a security issue it’s due to bad programming and should definately be disabled. Can’t think of any performance gain here, unless the traffic is in a loop.

Just a personal comment. I used to use Azureus, but found it too slow and cumbersome. Switched to Bittorrent, but gave that one up too due to resource usage and system performance degration. I’m now using µTorrent, which is both easy to use and light on your system resources. Actually the fastest and easiest torrent program I’ve seen to this date.

You don’t have to use the skip loopback if you don’t have problems.
You can try this if you have any kind of problems with other programs or so.
Other users that have problems with Avast Webshield say that this can solve it.
I past a quote from help in CPF.

Skip loopback (127.x.x.x) TCP connections Loopback connections refer to the internal communciations within your PC. Any message transmitted by your computer through a loopback connection is immediately also received by it. This involves no connection outside your computer to the internet or a local network. The TCP option is not checked by default because, in the case of someone using a proxy server, there is a higher chance of attacks being launched using a loopback connection.

Hope this helps.