AVG email scanner

I have been using Comodo firewall three or four weeks no problems.Today The AVg scanner could not connect to my Pop3 server to receive emails.I had to exit the Comodo firewall to receive my emails.Any help would be appreciated.The Comodo version is I am using Windows Home XP service pak 2

Hi Tommy,

and welcome at the forum (:WAV)

Check if you have “svchost.exe” blocked. Some programs use it to comunicate with the net and if you block it they cannot connect. :wink:

Thanks I will check to see it SVCHOST.EXE is blocked or not.But when I started up my computer this morning the AVG email scanner connected fine and checked for emails/. Thanks for the help

Today my e-mail scanner turned off and will not come back on! (just randomly)

I’m using AVG too and Comodo Firewall, I get that problem too. More often than not, when downloading emails from pop3, the AVG would scan them, however that process gets stuck at some loop and emails would not get downloaded. At which point, I have to wait for them all to time out and the process to end before trying again.

I read on the forums that one way to solve this is to add the avgemc.exe with parent services.exe, and check the option “skip advanced security checks”.

Getting the same thing here.

I will get POP3 errors in my email client. Eventually the AVG email scanner will deactivate itself. Have to activate it manually to get it going again.

All the rules for the AVG email scanner are defined properly.

I believe v2.2 was fine. Only when I went to v2.3 did I start having this problem.

So I’ve created a rule to allow the AVG email scanner unrestricted access. I’ve also skipped the parent check. Allowed invisible connects and turned off the advanced security checks.

Still I will get POP3 errors at times. Sometimes I get no errors at all but my email client does not do anything. All of this is always followed by the email scanner deactivating itself.

Also, I’ve gotten popups after I rebooted windows regarding the email scanner even though I gave it unrestricted access.

Normally if I let CPF create rules for the AVG email scanner I get about five of them. There are rules which have as the parent Explorer.exe, Svchost, and some AVG module. Never saw one for Services.exe although I added that but it didn’t help the situation.

Something is not right between CPF and the AVG email scanner.

Is there a way to tell CPF NOT to get it’s hands into the AVG email scanner at all? I thought I did this already.

How do you add avgemc.exe with parent srvices.exe to correct the problem.I have tried but can not find where to do this.

Adding services.exe did NOT correct my problem.

If you want to try it for yourself just add a new rule under Application Monitor and use c:\windows\system32\services.exe as the parent.

I tried the option to skip parent checking thinking that would fix my problem but it didn’t.

I am using Mailwasher as my email client. I check 2 POP3 accounts and most of the time I get an error on one of them. As a test I am only checking one account. Maybe the problem is related to checking multiple accounts. MW does the checking simultaneously but does have an option to do the checking one account at a time. Maybe that is the answer. I’ll try that later.

I believe the only thing you need is to set avgemc.exe to “skip advanced security checks”. In fact, I have that checked for all avg processes like avginet, avgw, avgcc. Advanced checks creates a pause and AVG does not like being interrupted.

At the moment I created one rule for avgemc.exe. I am allowing all activities and skip advanced security checks. I skip parent checking. Also allowing invisible connections just for good measure. This should allow every request to get by CPF.

I also set up Mailwasher to process my two POP3 mail accounts in sequential order instead of simultaneously. I have a gut feeling this might be the cause of my problem. Perhaps checking more than one POP3 account at the same time is ‘confusing’ CPF.

I’ll be monitoring this to see what happens.

I have tried all the suggestions I have found in the replies and they work for a time then the e mail scanned can’t connect to my Pop 3 to read my emails.i have to disable Comodo firewall to get my emails.I did like the firewall but this is all too much trouble so I uninstalled Comodo. Thanks for all your help but it just would not work for me

Might as well give my results too.

As I previously said I use Mailwasher to get my mail. I was grabbing my mail from two POP3 accounts I have with my ISP. I was using a mode called “Simultaneous Checking” when checking my email account. This is the recommended method btw.

There is another option called “Sequential Checking”. After I started using this method I have not had a single problem with getting my mail. Neither has the AVG email scanner deactivated itself. I’ve been running this way for two days. I should have had problems in this amount of time.

I am quite convinced my problem is CPF v2.3 related. I ran without CPF for a few days with Simultaneous Checking enabled and never once had a problem. I also ran this way in the past with CPF v2.2 and never had a problem.

Perhaps CPF v2.3 is having problems dealing with this Simultaneous method of grabbing mail.

I too use Mailwasher and AVG and had no problems accessing my email while I was using ZoneAlarm; I also have multiple accounts through Mailwasher and am having the same problem with getting my email as has been described. I will get some of my emails from a couple of my accounts and then everything stops with TCP/IP errors showing up in Outlook Express; if I wait several minutes and then try to download my mail one account at a time in OE, I might get all of the mail that’s showing up in Mailwasher. I’ve tried the other suggestions (disabling security checks, etc) but no joy.

However, I was unaware of the “sequential” setting in MW - I will have to try that when I get back home (I’m typing this from my laptop which doesn’t use Mailwasher nor AVG (I have Avast installed on this machine) but does have Comodo.

One other thing I’m also seeing with Comodo that I did not see with ZoneAlarm: I get several commercial html emails from various retail outlets such as Borders and DAZ Productions. With Comodo, in spite of the fact that I DO have OE configured to allow images, they do not download well; I’ll get maybe one or two images in OE but the rest will not come through. Any tricks to getting Comodo to let the full email download? I’m on broadband and this is getting frustrating.