AVAST Home Edition - Problem to update


I get this error during the day, my PC is on and AVAST tries to update:

“An error has occurred while attempting to update”

AVAST Home Edition Version 4.7.1098

However, if I run the update on a manual way, it works, as well as when I boot up, the updates are also successful :THNK

Thanks for your help


I have the same version of avast! as you, but mine updates without any problems. From what I remember I had to give permission for avast! to update twice - once for manual updates and again for the auto updates.
Have you been sitting at your computer when avast has attempted to update? If not then you might want to try rebooting and see if any popups are generated (my avast! often seems to try and update after a reboot), if you are not present when it tries to update then you will be unable to give permission - unless you go to your application rules and give permission that way, which is something else you might like to try.

Edit: Sorry just realized you’ve tried rebooting - I didn’t read your post properly the first time (strange it auto updates that way then wont later on). Maybe you should check your app rules again - possibly try setting avast! as a trusted app. As I said before mine updates fine - so if you persevere I’m sure you’ll get it sorted in the end, good luck :slight_smile:

P.S Try checking your logs to see if there are any blocks relating to avast! in there (I would check Firewall and D+ logs - just to be sure).

Do you get any messages in the D+ log? For the Network Policy, avast.setup should allow TCP and UDP out. And in D+ be an installer or updater. There are a number of other avast entries in D+, and they may need to be set as trusted to make it all work. I don’t remember which go with automatic updates, and they might not be the same in XP as Vista anyway.

same here, I got Avast updating automatically without any problem. Just make sure AvastSetUp is set as trusted in Def+. You should be prompted by Def+ on the first time Avast is trying to update after a new CFP install (otherwise the auto-updater is a service that doesn’t need any special setting in Def+; I actually found that it could be active without appearing at all in the Computer Policy of Def+ ??? I had to ad it myself :SMLR to protect it against process termination).