Avast 7 and Comodo 6 Firewall?

Some time ago there was a bug between Comodo and Avast. I was wondering if its fixed in the beta?

Have anyone using Avast with Comodo Firewall came across any bug?

I don’t think it’s fixed. Anyway you will have to wait until Comodo 6 RC to see.

But as far as I know it’s Avast issue they need to fix it in version 8.

Thanks for your reply. It is said to be fixed in Comodo 5.12.

Can someone please test this out?

I believe it is supposed to be compatible with V6, but I haven’t heard of anyone testing it. If the problem is still there I think it would be worth filing a bug report over.


ill mess with it. installing cis now in vm

so what do you guys think is the best way to test this? it seems to be fixed from what i can tell. i only installed the firewall and set it to proactive security then i set the firewall to custom ruleset then opened IE, i got an alert for localhost (screenshot attached). i also added a blocked rule for IE and it worked as expected.

i think the “filter loopback traffic” option in the firewall is what fixes the problem. if you guys want me to test it another way let me know.

[attachment deleted by admin]

True but nobody is using 5.12 on Windows 7. It is created for Windows 8.

I’m actually using 5.12 and I’m on Win7 pro 32bit.

Why? The only reason is prob Avast? I don’t see any other point.

Q: I do NOT use Windows 8 and I have CIS 5.10, do I need to install CIS 5.12?

A: No. You do not need to install CIS 5.12.

Q: Is CIS 5.12 going to provide more security than CIS 5.10?

A: No. The only difference in CIS 5.12 is Windows 8 support.

Let’s stay on topic here. :P0l

This topic is about CIS V6 and whether there are still problems when running i talongside Avast 7.

Well, i somehow can confirm it is fixed but not by 127.x? Running Win8x64 RTM Enterprise Trial with Avast 7.0.1473 and Comodo Beta 6.0.252829.2560 and iexplorer as well as Pale Moon. Further i have add. rulesets like “Local and NW” that allows: Loopback/Multi-/Broadcast/Private Networks.

  • Filter 127.x.x.x active – Setting: Blocked=Block, Web Browser=Block, Local and NW=Allowed (some websites cause an alert, one remark guilty in general for all rulesets: don’t forget to set an rule to ask/block else, cause in a check without such a rule comodo didn’t ask and just permitted the connection to https. for https it’s no problem but on other connections you want to avoid it), Trusted App=Allowed (with no alerts for sure)
  • Filter 127.x.x.x deselected – Setting: Blocked=Block, Web Browser=Block, Local and NW=as above (so http allowed, https asked/blocked - tried both), Trusted: Allowed (again no alerts)
    So filtering 127 or not doesn’t change something.

What i wonder about is why “System” is trying to connect sometimes when opening a page?

EDIT: Solved: And (to make a ruleset for web browsers using webshield) why “Local and NW” works while “Web Browser” doesn’t? Checking KillSwitch there are just local connections (that are allowed in Web Browser ruleset) on the browser and AvastSvc (that is fuly allowed) connected to the remote adresses. Solution: it was DNS. First i added 53 to HTTP Portsets but then i realized no UDP Out rule does exist in default Web Browser ruleset (or got deleted cause ruleset-handling is somehow buggy), so adding a UDP out on 53 allows browsers using “Web Browser” to connect.

Seems like a lot to do to get it to work.

It appears to work just fine alongside CIS V6 with no changes to the configuration.

do you mean comodo firewall 6 or comodo internet security 6?

Sorry, good catch. :wink:

It works just fine alongside Comodo Firewall V6. I did not mean to make it sound as if I advise running two full-fledged antivirus programs alongside each other.

Thank you.

Well you could have CIS6 with JUST the Firewall installed and IIRC in version 5.10 it still was labeled as CIS in the uninstall menu even with just one component installed.

hoping and waiting for Chinese Simplied version